Read Netlist (not responding)

everything use to work, these are 6 month old projects… used netlist a thousand times ok before…

now when trying to read the netlist… PCB just hangs,
I try a few different project’s PCBs, they all hang now…

try to add a footprint in schematic: yes, that still works.

Application: kicad
Version: (5.0.0-rc2-178-g3c7b91b96), release build
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:

its working now…
I didn’t do anything,
just waited 30 minutes while not responding. ,
now its instant…
all boards work now…

thanks guys…

Aggravating this is you may never know. I’m on Linux so checking for background processes and other things is more or less second nature. One thing that is annoying is sometimes I’ll open a window and think it is closed and nothing seems to work. I’ve learned to minimize all windows to see if the thing just got moved to the back of the visual stack. If I accidentally minimize it the fun really begins because as a sub process it doesn’t show in the tool bar so I can bring it back up.

" if the thing just got moved to the back of the visual stack"

It could have been, except I exited and reentered many times to test other projects…
I work with 2 instances usually running, as it was during some of those tests…

not sure what fixed it…
didnt reboot…

And now another example of why I call it Windoze

Am using Version: 5.0.1+dfsg1-2~bpo9+1, release build in Debian linux. I have discovered through trial and error that if Kicad 5.0.0 repeatedly fails to act in the way you think it should one strategem to remember is to shut the program completely, and then restart it before retrying the action.

The 5.0 series is relatively new. There certainly are problems not found and fixed yet. It would be important to get them reported properly so that the developers at least would be aware of them and hopefully even fix them.

I know it’s difficult when you don’t remember exactly what you just did and even when you do, you can’t repeat it. But still. With a bit of luck someone else sees the bug report and can give more information or at least confirm the problem.

1 Like

I literately walked away from the machine for 30 minutes…
when I came back to my surprise, it had read the netlist… like it was instant…

Yes, closed the application opened and closed several times for a few projects, all blocked. none would process the netlist.

I left the last one waiting, and walked away…

When it worked, I tried the other projects, they worked too…

my slow internet, maybe somehow related to the issue…
(my internet is slow because Acronis is backing up my HDD to the cloud.)

Is it possible that you still have the old kicad 4 github libraries setup?
Check your fp lib table and make sure it does not point to github directly but to local files.

You might want to take a look at this: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.