Rats nest not updating and schematic components absent from Layout

I am making a kiCAD layout from schematic:

However when I click the export to PCB new button I am getting some errors that say component has not been associated:

I double checked the associate footprint through CvPCB step to ensure that all schematic components had an associated footprint

I also double checked the PCB library tables within PCB new to ensure the path to my custom library ‘smartclassic’ is present. I also added it to the project specific libraries , just in case:

Can anyone help me figure out what’s going on ?

EDIT: I wanted to snap shots for each of the steps detailed above, but the forum only allows one photo to be uploaded

This is the PCB library table

I have found the root-cause of the issue that my custom library does not have components anymore: I do not know what caused this to happen? Is there a way to retrieve and “place” them back from a previous archived folder?

Thank you @Rene_Poschl
I want to assign the foot prints using the option 2 you have shown. But my custom library has no parts anymore.
Where can I check if I want to retrieve them?

Basically, I have done a bunch of work in redrawing the schematic files and would not want to redo the work from the scratch.
I am able to “place” the component from library in eeschema, but not able to associate footprint

Never ever use the cache lib for your own symbols. This lib is a special lib that must be considered part of the schematic file! only kicad itself should ever write to it.

You might need a lecture in proper lib management. Luckily i wrote one: Library management in KiCad version 5

This does however not really apply to the footprint side as there is no cache lib there. I have no idea why your footprints have vanished from the lib. Maybe you deleted the file or you moved it or renamed it. Could also be that there was a bug on saving or you do not have the right file permissions.
I really can not say more without you providing more info on how you made that lib and what you did since you last had footprints in it.

1 Like

If you navigate to the directory listed for “SmartClassic” are there any files in it?

Hi @Seth_h
I have two .lib folders listed here:

I deleted it from the table with the intention of re-adding it later. But the library isnt visible no more.

Deleting something from the library table will not delete it from the file system. This means it should still be where you originally saved it. (A footprint library is a file system directory with with suffix .pretty containing one file per footprint with extension .kicad_mod)

Your screenshot looks strange. why do two of these files lack the file extension while all others have them? (And why are they still listed as lib file? Is this just strange behavior by your operating system?)

OK. It sounds like you are mixing up footprints and schematic symbols. You have the SmartClassic directory in your footprint table but it only have schematic symbol libraries in it.

1 Like

I do not know the answer to the last question. It was stored by default.

if @Seth_h is correct than this might be a valuable resource for you: What is the difference between footprints and symbols?

Well by now i might as well link the full FAQ: (Start Here) Frequently Asked Questions

1 Like

Windows. “Hide known file extensions” anti-feature.

1 Like

I knew about the “hide extensions” feature. Never imagined they are able to come up with something worse than that.

@Vish i suggest you turn on file extension visibility to make your live easier by seeing what a specific file really is. First google result for how this is done: https://www.howtohaven.com/system/show-file-extensions-in-windows-explorer.shtml

@Rene_Poschl @Seth_h
Thanks a lot for your kind help. I am set now…
Ultimately I found the root cause for my problem through the FAQ index thread. The pin number in the schematic was not the same as the pin numbers on the footprint.

There should be an option to mark this as the right answer, on the forum- like how Solidworks does.
It will save users a lot of time going through the discussion

@Vish You got your issue sorted out in 9 hours, and quite a bit of extra information.

The problem with “marking this as the right answer” is that in a couple of weeks the official stable version is going to change yet again. @Rene_Poschl gave you the best answer yet,

This FAQ often gets updated before the official documents do.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.