Randomly changing trace widths

I have encountered an unusual bug. I have an almost complete board, and have been going through it beefing up power traces etc. KiCad, for some reason, does not seem to recognize that modification - say, lengthening - of a given trace, becomes a part of the exisiting trace. Electrically it is ok, but if you need to delete or change the width of that trace, you need to do that to every little piece you may have added.

What has happened to me is that while changing the width of a trace, I encountered a trace that increased in width by itself. Upon examining the entire board, I found numerous instanced where the trace width had changed. If it was a trace that had additional segments added to lengthen it or where it angled to connect to a node, some sections of the trace had changed width, and some hadn’t. It was random and occurred on all 4 layers.

It has taken hours to fix it, and I’m still finding instances of it. I can accept that I might have screwed up, but how? What could I possibly have done to cause this to happen?



There are some options for changing lots of tracks in a single go with for example:
Pcbnew / Edit / Edit Track and Via Properties

If you have any selection of some track segments, and edit them either via the e shortuct key or via the popup menu, you can (acidentally?) change the width of those segments.

Don’t go bashing on your keyboard randomly with KiCad. Far too many shortcut keys for that.

Don’t understand your point about “bashing on the keyboard randomly”. I use the e key to edit trace widths. Never tried to edit more than one at a time. In one case, when I tried to change the width of a segment attached to a pin, I got a warning that it would change the net on that pin. I have no idea why. Had to reassign the original net to that pin. But it’s all good…for now.

Thanks - Bruce

Every now and then I accidentally do weird things with my keyboard. For example my mouse drops out of my hand and falls on the keyboard, or you press a few buttons when you move the keyboard, or a book is laying on it which presses some keys.

Things like that are easily forgotten, or you don’t even consciously notice it, but it can have weird results in a program with many shortcut keys such as KiCad.

It would be very helpful if you could name your KiCAD version Help->About->Copy version info, this way other people could try to reproduce the issue or offer their own experiences.

Strange things can happen in KiCad nightlies (like https://gitlab.com/kicad/code/kicad/-/issues/5886). Thank you for bringing up your observations. Now, ideally you’d still have “before” and “after” files to compare. KiCad does produce auto-save zip archives which you can rescue next time, along with the broken state of the project.

To save you some future trouble, I can recommend using git locally to keep track of relevant changes in your project. I’m sorry to hear you had to wrestle through that for hours.

So - it wasn’t necessarily your fault. It would be important to know what happened, so observation is key. Furthermore (as der.ule already pointed out) there are tens of commits every day, which makes it rather crucial to know exactly at which commit the version you’re using was built to track down possible causes of the behavior.

I’m using 5.1.6. Still straightening it out. Since I don’t know when this started it’s not as easy to go through the backups, not to mention losing everything I’ve done since then. So I’ll keep editing. Good thoughts about accidentally hitting unknown keys; I’ll keep that in mind. Almost ready to ship this one.



if I understand this correctly, you have some tracks on top of each other. Using Edit->Clean up tracks and vias, you can tell KiCad to take care of that for you (don’t forget to refill your zones beforehand, if any)


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.