Racal Cadstar import

Just installed KiCAD 5.1.10_1 on Windows 10 (new user). Looking to try to import Racal Cadstar projects as my current PCB tool can export to Cadstar, so it seems a possible route to importing old projects to KiCAD.

Found this - https://www.kicad.org/blog/2020/09/Development-Highlight-CADSTAR-PCB-Importer/.

However, when I click File >> Import, and should get options of netlist, specctra session, graphics, non-KiCAD board file (which seems to be the route to Cadstar import), all I get Eagle.

Maybe I am missing something?

All these new features will only come with version 6 of kicad. They are in the current development version – the so called nightly, but use that on your own risk Is it a good idea to use a nightly build version?

Ah, OK, thanks. Not urgent, but might look at nightlies if it becomes so.

@Nick_W I would be very grateful if you could test out the importer and report any bugs / import inaccuracies that you might find. I have tested the importer with all the designs I have and fixed all major issues I could find but it is always good to have more people testing it.

You can download the nightly version of KiCad here: https://kicad-downloads.s3.cern.ch/index.html?prefix=windows/nightly/ Make sure you scroll all the way to the bottom in order to get the latest build.

Certainly will.

Bear in mind though that I am merely trying to use Cadstar as a stepping stone from the original system (Seetrax Ranger) to KiCAD. Ranger has a Cadstar export, KiCAD a Cadstar import. So, I won’t have any ‘real’ Cadstar projects, and if Ranger export gets it wrong, it may all fall flat on its face.

However, watch this space. I don’t know if the nightly will wipe out my 5.1.10, but I guess I can always reinstall it.

Bad start. Cannot get Ranger to export anything meaningful at the moment.

The Windows installer automatically installs 5.99 independently from 5.1, they co-exist happily.

1 Like

You can open your exported Cadstar design in the Cadstar design viewer (available here: https://www.ecadstar.com/en/resource/cadstar-viewer/ - requires contact details). This will allow you to check if the problem is in KiCad’s importer or Ranger’s exporter.

Note that the KiCad importer requires .cpa and .csa files (i.e. cadstar PCB/Schematic archive files). It does not work with the binary .pcb or .scm.

As eelik said, the installer should install 5.99 in a separate directory so you shouldn’t have any problems.

Finally, just to say that you should really use the “Project importer” as that will load both PCB and Schematic in one go.

No luck so far. Downloaded the Cadstar viewer, but it didn’t like the export.

Really don’t know what Ranger XL has done. It just gives you a dialog with a choice of Cadstar 6 or 7 (seems to be Cadstar for DOS, so must be very old), and a file name. What it came up with (along with a load of errors) can be found at


It didn’t even add the .CPA extension, I did that. Maybe the file contents (text) mean something to you. The design is perfectly viewable (schematic and PCB) in Ranger so there is nothing wrong with the original project.

Unfortunately there is zero information on the Cadstar export in the Ranger docs, and I cannot really go back to Seetrax and ask them. Firstly they don’t support Ranger XL any more, and secondly asking them how I move projects from their tool to someone else’s is a bit much.

Yes it looks like your exporter generates a “CADSTAR 7 (for DOS) PCB Initial data” (usually it has a “.cdi” extension). This is not compatible with KiCad’s importer as it is a different file format. In any case, it should be theoretically be possible to open it in CADSTAR and then re-export as a .cpa file. Obviously you’d need a CADSTAR license to do this…

Unfortunately, when I tried opening it in with CADSTAR 2020.0, I got some errors:


Looking closely at the file and the errors it is reporting, my guess is that that the issue is a slight incompatibility between Ranger XL and CADSTAR: In CADSTAR any tracks (routes) must start and finish at the exact same coordinates as the centre coordinates of the pad.

If you open the file in a text editor, you can see the two line numbers that the errors are referring to:


I don’t know anything about this file format, but if I were to make a guess, I would say component TR4, pad number 3. If you can edit the design in Ranger XL and look closely at the connections to TR4, pad 3. Maybe you can re-do the connections in such a way that they terminate exactly at the center coordinates of the pad?

Yes, your assumption is good - except that the track is centred on the pad! Or at least, it appears to be.

In Ranger the unrouted tracks (unroutes) are created pad centre to pad centre, and when you convert them into real tracks you segment the unroute (rubber banding), putting the corners where you want to get the track through, setting segment to layers, adding vias etc, but what you usually do not do is move the ends off the pads. You obviously can, you can put anything anywhere - it just is that there is seldom a benefit in doing so, and from what I can see I didn’t in this case (though it was a long time ago).

It could be a rounding error. The package is a TO-126 and the pin spacing does not fit neatly on a 0.1" pitch board (0.1, 0.05, 0.025 etc) - the pitching is 2.29mm, or 0.090". I probably just put the pads where the datasheet said.

For the purposes of a test, I guess I could move things around - but is there any point in reality? This Ranger export spits out Cadstar for DOS, your import wants something more recent, and as you say, I do not have a Cadstar licence, so as a means of transferring the projects it won’t fly. The Ranger XL version is about 2004/5 I think, and DOS was long gone by then, so I guess it was only for legacy use even then.

It does have the option of outputting Cadstar 6 or 7, but I’d guess 6 is an even earlier Cadstar for DOS?

If you want me to do anything as part of your testing the importer, happy to do so, but as a means of transferring my projects, not practical, I think.

If your old program can generate gerbers, you can open them in KiCad’s gerbview and export them to a KiCad PCB. This process is not perfect, but it is a whole lot better compared to re-designing the PCB.

What you get is:

  • PCB outline.
  • Mouning hole locations.
  • All tracks.
  • Netlist (Implied in the tracks).
  • Footprint locations (Implied in the ends of the tracks).

I once did this from a Protel project, where I re-created the schematic from a .pdf file. Then assigned footprints in EEschema, and placed them over the track ends from the gerber back-imports.

I made a few errors in the schematic, and those were caught because they generated DRC errors on the PCB because the netlist on the PCB did not match with the schematic.

Yes it probably is off by a very small amount - rounding error like you say.

If you can get it to open in the CADSTAR Design Viewer, you could send me one or two of your designs and I convert them to cpa/csa to test whether the process works.

In terms of testing the importer, don’t worry about it. I originally understood you were able to export to CADSTAR Archive (.cpa /.csa) but this is a bit more involved. I’m just curious if there might be a way for this to be done semi automatically.

Your other option, as paulvdh says, is to try the gerber import.

Yes, thanks, I think that may have to be the route. Not having much luck with the Ranger export. Probably none of these designs will need serious modification - if any, and, like you say, schematics are easier to recreate than layouts.

OK, thanks, I am working through old designs, and they are throwing up errors of one sort on another - don’t think Cadstar likes these Ranger designs much. I’ve got one so far that loaded up, but the exporter threw a lot of errors doing it, so not clear how much is there - but at least the Cadstar viewer loaded it…

I’ll post it for you to have a look at tomorrow.

I just had a play with the file for a bit and removed all sections that were referring to TR4, pad 3. I managed to get an import into CADSTAR sort of working (sorry I can’t generate a .cpa file right now as
I don’t have the license with me but can try tomorrow)

It definitely seems that to get this working you need to re-do the connection to TR4, pad 3 or remove it completely (as I did).

Well, interesting, doesn’t look right at all. There’s a load of tracks there that just seem to go straight from A to B across everything else. What it is supposed to look like is https://drive.google.com/file/d/1wZur3xg3aYe1wOBnR3Uz5w9wOc-VBX95/view?usp=sharing.

When the export ran, it produced a load of errors, for example:

ERROR : Signal 43 :-
2 artwork features have not been exported !
ERROR : Signal 22 :-
1 artwork feature has not been exported !
ERROR : Signal 49 :-
1 artwork feature has not been exported !
ERROR : Signal 52 :-
2 artwork features have not been exported !

and so on. I’d guess that for whatever reason, it has disliked and missed out a load of corners relating to those tracks.

Since I plotted the pads as outlines only, you can actually see on the bottom pad of TR4 (2/3rds up on the right) that there is a short final vertical section (on both red and blue tracks actually) that takes it to the pad centre.

I actually tried to remove the suspect TR4 / VR2 track completely and remake it definitely pad to pad in case I had moved it, but for some reason couldn’t start the new track on the ‘off grid’ pad centre - haven’t used Ranger for so long cannot remember how to do it - need to read the manual!

However, the conclusion I am coming to is that this exporter just doesn’t work, or more likely it does, but to get it right the projects all need to meet some specific rules to be Cadstar importable (like the TR4/VR2 track must end on pad - which doesn’t actually matter to Ranger providing it makes contact and obeys design rules). Therefore, unless I knew and obeyed those rules while laying out the boards - and I didn’t, most projects are going to have problems.

This (https://drive.google.com/file/d/1eg4WRT2fDgK7YX3zYM28aer0fX253Qw7/view?usp=sharing) is the first one that did export and import into the Cadstar viewer without errors (albeit lots of warnings in the viewer, and errors again on export). However, it looks a total mess in the viewer. Tracks everywhere. Yet again, in Ranger this is a working board that meets all DRC.

Think that in practice the Ranger XL >> Cadstar exporter is a non-starter! This is no reflection on your importer of course - never got that far. It is all Ranger.

Yes it does look like the Ranger exporter doesn’t work very well… Are there any other file formats it exports to? e.g. RINF?

Yes. The options are: RNIF netlist, Cadstar, GenCAD ASCII and Bath Scientific Test Data.

Think RNIF was used for transferring from OrCAD schematic capture, but not sure. Somewhere I worked a while ago used OrCAD for Schematics and PADS for layout - think RNIF was the bridge.

Don’t know anything about GenCAD but I’ve heard of it - got a feeling it’s aimed at transfer to manufacturing. Interestingly, the errors that appear on exporting Cadstar do not appear when exporting GenCAD.

No idea what Bath is.

I assume you mean RINF (not RNIF?)

If so, you can also try posting the RINF Netlist export - Either .frs (Full RINF SCM) and/or .frp (Full RINF PCB).

It is also possible to import that into CADSTAR, so it might be worth a try.

Yes, RINF.

This link (https://drive.google.com/file/d/1JggtnAThOBAw9YWSeAwRwunbck8mP3t3/view?usp=sharing) is to the same project as originally, exported and saved as test.rinf. (Ranger doesn’t even give it an extension, I stuck that on the end). No errors came up on export, but the Cadstar viewer said not enough information to open, try import. Only thing is, doesn’t have an import.