%R Unexpected Behavior


#1

I have this:

When I am expecting this:

Both have these properties:

There is nothing apparently different between the two symbols; even with a text editor I can not determine any difference that may be causing this behavior.

Anyone have any ideas?


#2

It’s REF**, not **REF.

%R is the “secondary” refdes; it tells that it’s replaced with the same text as REF**.


#3

Is this fixed in the version you are using?

ON EDIT: Note, that the “**REF” text was auto-generated by KiCad by the field having “%R” in it.


#4

In the official libraries REF** is used in the Silk layer, %R in the Fab layer. But when you look at the view (the fp editor or the board editor), you see REF** in both layers until the footprint receives the reference designator from eeschema.

I have a development version here, but the rules should be the same.


#5

I don’t think this matters. At least not if used in the real reference field. It would matter in the user text field. (Meaning in the second reference field)


#6

Ah, I didn’t know that, only checked a footprint.

I hope my previous post answers to Sprig. You write %R in the field but see REF** (or **REF) in the view, that’s normal.


#7

In the footprint editor yes. In pcb_new only if the footprint has no connection to a symbol (meaning if you manually added the footprint to the board) And in that case you would have both shown as Ref**, not one as U1 and one as Ref**


#8

Text in the one that works as expected:

(fp_text reference **REF (at -3.175 -5.842) (layer F.SilkS)
(effects (font (size 0.762 0.762) (thickness 0.127)))

Text in the one that does not work as expected:
(fp_text reference REF** (at -0.1 -3.9) (layer F.SilkS)
(effects (font (size 0.762 0.762) (thickness 0.127)))


#9

This is only one of the text fields. Maybe also show the user text field


#10

Are your footprints from the footprint files or from the board file? Who made them? Can you give the whole files?


#11

All seems fixed now… I made quite a few changes while working through this, so I am uncertain what the underlying cause was.

Just out of nowhere I happened to pick the only symbol that had “**REF” in it’s Footprint. And, I have no idea how that got there.

While working through the problem, I had placed “REF**” in the field for the problem Footprint; such was the case when creating the screen-grabs.

What a head scratcher.


#12

I should pay more attention to original posts; I can see the screenshots are from a board.

Good you got it fixed, but we still don’t understand how it happened. Can you clarify, which one actually worked, REF** or **REF? Do you mean that one of those two possibilities didn’t work at first and when you changed it, it worked?


#13

I have no idea what the underlying cause was.

My mistake was not making only one change at a time. I forgot to go back and change the field in Eeschema; from “REF**” to the tilde “~” symbol that I typically use.

I have gone back and

**REF

and

REF**

seem to be interchangeable.

There was probably just some typo on my part that I just could not see.

However, THANKS! for the help; the comments really helped me to focus and get things back to normal.