QFN wizard generates wrong pad sizes

The QFN Wizard generates wrong pad sizes.
It seems that the wizard always draws rectangular pads (if “Oval” is off) and that the value for “Fillet” is added to the length of the pads.

I exaggerated this in the screenshot below, by making square pads (0.2 * 0.2mm) with a large “fillet” of 1mm. This generates pads with a length of 1.2mm, while the pads are square when I set “fillet” to 0.

The QFN footprints in the library have a fillet radius in their corners, but with the current QFN Wizard (In KiCad V5.1) I can only generate “oval” or rectangular pads.

There have been more problems with the pads for QFN. I found this in the bug tracker:

I’m not sure If this should be filed as a separate bug.

We do not use the wizard for the official lib as it does not provide any increase in maintainability and is quite frankly bad in general (Unless the recent update truly fixed everything but your screenshot does not look like the required degrees of freedom have been added.)

We use this one: https://github.com/pointhi/kicad-footprint-generator/tree/master/scripts/Packages/Package_NoLead__DFN_QFN_LGA_SON

1 Like

I already had my suspisions that:
a). The official libraries were script generated.
b). The Footprint wizards were out of date (probably from V4, before fillets).

It would be nice to have working Footprint Wizards. They work quite nice for generating footprints with lots of pads.
For what I know the rounded corners are usefull for better release of solder paste from stencils, and the wizards do not seem to support it.

Maybe it should be filed as a bugreport or on the wishlisht to improve the footprint wizards with the capabilities of the V5 footprints, and use the same Python scripts as the official libs. Using different scripts for the same footprints seems very silly.
I’m a total python noob thouh.


FWIW, JP Charras committed a modification to the QFN wizard few hours ago:

It’s not (yet ?) cherry-picked to the 5.1 branch.


it was me who brought the topic up in the EEVblog Kicad forum, many thanks to paulvdh for taking it to the Kicad forum here. I checked the patch and while it fixes the problem of incorrect footprints, it applies the new “offset” parameter in a totally un-intuitive way: the pads are moved outwards by offset/2 instead of just offset. This makes it unnecessarily convoluted to compute the correct offset if you try to match the land pattern of a chip from the vendor datasheet. I think this should get fixed before it goes into a release.

How can I help to get this done?


1 Like

Follow this link:

Raise this as a bug against 5.1.0
As this does not cause file changes, I can’t see why is cannot go into the 5.1.x branch.

Filed a but report as:

The bug was originally discovered by thinkfat on the EEvblog forum:

The fix has been fixed :wink:

Only in master branch for now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.