Problems with wire connections in KiCad ver. (5.1.5)-3

Hi everyone,
on the 18th Dec. I downloaded Kicad ver. (5.1.5)-3 beause I had problem with the disappearing measuring scale in Eschama in Kicad Ver (5.1.3)-3. With the new version (5.1.5)-3 everything was o.k. again and I could finsih my old project.

Today, I opened a new project with the new KiCad version and am now having problems in connecting components directly with each other (i.e. overlapping terminals) or through wires. Unfortunateyl it is not working at all. I think this might be a grid setting problem but I cannot succeed in wire connections even with the finest available grid setting.

To illustrate my problem more precisely, I have attached a screenshot of a test_project problem decription and hopefully all relevant information.
I haven’t made any changes in my windows system recently. This is probably some primitive issue of system settings but unfortunately also a bit irritating.
Looking forward to your kind advice.

Thanks and best regards
191220 Problem report KiCad (V 5.1.5)-3.docx (56.9 KB)

The default and recommended grid is 50mil
You have 1mil

1 Like

Are these standard components from the KiCad libraries, or did you create them yourself?

Is it possible you placed them using a non-standard grid, such as a metric grid rather than the standard 50mil grid?

I suggest you post the version info for KiCad (Help -> About KiCad -> Copy Version Info), and attach a copy of your example schematic (the actual schematic file, not a screen capture copied into a Word doc).

Yes, I agree with you about 50mil being the default value.
Actually, I had also started with that. It is only after I found that the wires are not connecting I experimented with higher resolution in order to get somewhere. And thus 1mil grid setting is just one of my multiple trials.
Also, with 1mil grid, the “cross-hair” and “mouse stylus” are closest to each other. If I remember correctly, in Ver. (5.1.3)-3 and even in ver(5.1.5)-3 just two days ago the cross-hair and mouse stylus were congruent. So, something is wrong with my settings today.


  1. All symbols except for U1G and U2C are from original KiCad symbol library. I had made U1G and U2C ( and many more power terminal symbols for TTL logic devices) myself because the physical size of original KiCad symbols was/is too large. In my previous project there I needed many such TTL logic gate device symbols and using my small sized symbols was a real advantage in terms of space saving on the sheet. And, there was no such problem as I am having today.

  2. The Kicad version copy is:

  3. The test project file is attached herewith for your reference.
    Test_proj.sch (5.3 KB)

Thanks for all your efforts in trying to help me.
Best regards

Your symbols are not aligned to the grid. For example, here is a screen-shot of C1. It’s a bit hard to see, but if you look at the end of the upper pin you’ll note that there is a grid dot just to the left and a bit below the tip:
The reference point of this component is placed at (4705, 4097) on the page, which is 5mil too high and 3mil too far left to be on the grid. Moving this component onto the grid allows connections with another on-grid component.

Here’s another example showing the problem of off-grid placement:

Notice how the end of the wire isn’t aligned with the tip of the pin. If you move this symbol onto the grid, there are no problems connecting this pin to another pin placed on the grid.

I don’t see any problems with the construction of the symbols in this schematic, just off-grid placement. If you have problems connecting to symbols you’ve created or imported, remember that it’s critical for the pins in the symbol definition to be aligned to whatever grid you’re going to be using. We strongly recommend creating all symbols on a 50mil grid, and laying out all schematics on the same 50mil grid.

Unless you’re going to create all your own symbols and never use any of the standard symbols, don’t give in to the urge to create symbols or schematics on a metric grid. It will cause you nothing but pain.


Using metric grid is not a good idea with the current eeschema no matter if you are prepared to make all personal symbols or not. The unit value of the file format is 1mil. So any metric value must be rounded to the nearest 1mil unit value.


Just think of it a ‘unit less’. It doesn’t matter for the schematic.

1 Like

Thanks a lot RRPollack, Rene_Poschl and hermit for the ime you have taken to give me valuable suggestions. I will keep them in mind and hope to have less problem issues in future.
Thanks again and best regards

If you find the standard symbols take too much space on an A4 sheet, consider using hierarchical sheets to keep the amount of circuitry on a single sheet to a comfortable level.

Alternatively you can change the sheet size from A4 to something larger (File -> Page Settings). If you need to print on an A4 page you should be able to shrink the output to fit using your operating system’s print dialog, or print as a PDF and use the PDF viewer’s resizing capabilities.

@ RRPollack,
Oh yes, that’s an elegant alternative to drawing own symbols.
You notice that I am a novice and that my e-functional KiCad learning curve has yet a long way to go before it reaches the asymptotic phase. :grinning:
Thanks again and best regards

Hierarchical design is the core of how to efficiently use KiCad. It allows making more complex boards while still being able to read the schematic easily. See Hierarchical or flat schematic design, what is best for me? (How to deal with multi page schematics?)

Yes it is. But that way all is made smaller at print.
For me IC symbols (pin names size) are OK, but discrete in many cases took to much place. One of task I set for me myself on the way to begin using KiCad was to define my symbols. I don’t have them all ready yet. With each PCB I will design I will probably add few new symbols.
I prefer to have dense schematic at one A4 then to use hierarchical. Except doing the documentation of each PCB I collect only schematics. Having each schematic at one A4 makes my collection smaller.

But my decision to collect them printed has about 20 years. I’m not sure. May be nowadays the better decision would be to not print them at all and the number of pages becomes less important.

Of course measurement units are not so meaningful in a schematic. But I guess that KiCad was developed entirely (??) in Europe so the idea that native resolution would be inches instead of metric is surprising. Is PCBnew native in metric? Perhaps…such is the nature of legacy. We Americans gave up on metric many years ago (There WAS an effort to change to metric about 40 years ago) and I think that tires are now sized in mixed metric, percentage, & inches around the world.

The unit of pcbnew is 1µm.

1 nm IIRC. ------------

It’s because the US led in the semiconductor industry so the pin spacings and hence the grid dimensions are based on inches.

But Rene said that PCBnew is done in microns, which is metric. EESChema is in inches, but schematic dimensions seem to be of little consequence. So vaguely like tire sizes, we have mixed standards. Not a serious problem; more of a quirk of the world we live in…

There’s no contradiction. Internally pcbnew can work with different units and extremely fine precision but the interface is still in submultiples of inches.

There are lots of examples of this modus operandi in the world. Unix/Linux machines track time in seconds (and microseconds) past midnight 1970-01-01 plus the occasional leap second, but people work with the calendar time, and local time for that matter. The software bridges.

I don’t disagree with you. However, I think it is in pcb new when I set (I think it was some text to 0.03 inch height) it comes out with non zero digits far to the right of the decimal. Nobody is trying to align this text on an electron microscope, so it does not matter. But it is consistent with what Rene said, and I have noticed it.

1 mil is exactly 25400 nm, so KiCad does not need to round dimensions in integer mils