Problem with VIA and Zones


#1

Hi.

I’m new with Kicad and I’m trying to create a simple board with 2 sides, where bottom side is just a ground plane.
In the top, I’m using zone for ground too and I would like to add some VIA’s just to make a better ground connection (it’s and RF filter). I used to use Proteus in the past and there, I just add an VIA and set it to GND net (right click on VIA and properties). But I can’t do this in Kicad. So my question is: how do I do this?

I’m not sure if am I doing this in the right way, but to add via, I’ve clicked on “Add tracks and vias” on the right, then select VIA size on top bar, then click on PCB where I woule like to place via, then press ‘V’ and double click do disable/finalize track (so only VIA is placed, no track). This looks likes is working fine, I can see only via. The problem is that I don’t know how to connect this VIA do a specific NET (in this case, GND) so my GND Zone doesn’t create an space in theses VIAS (since it’s GND too!).

Another question is about Zone…How to I force to ignore island’s? I mean, I have and ‘island’, but I wish this is filled too with this Zone.

Thanks!


#2

The term you are looking for is via stitching.
Sadly the current version of KiCad has no direct support for it.
But there is a well documented workaround using single pad footprints.


Why? For what reason would you like this to be filled?
The only valid reason would be to save on edging fluid. But even there you should connect it to gnd if at all possible. (Floating planes can contribute to EMI)


#3

In KiCAD, you specify the net associated with a via by placing the via in a track. I don’t think you can place an isolated via, then assign it to a net after the fact.

Dale


#4

Thank you very much! I’ll try this solution!