Problem with several GND

Hi everyone,

I currently work on a project with a optical isolated part.
Thus, I use 3 GND names (GND_A, GND_B, GND) but I don’t understand
why I can use them in schematic but there are all named GND in the layout.
I have the same problem with the supply voltage symbol.
They are all named P5VDC in the layout but there are 5 power symbol in schematic.

Do any of you already had problems like that ?

Wild guess. Did you place a ground signal and rename it? KiCad has a slightly hacky way of dealing with power components and they are connected by hidden labels. You need to place one of the pre made power symbols or, if you make your own, look carefully at how these symbols are made.

Are you using any parts with hidden power pins?

I had that problem when I started to use KiCad in 2017 but not with GND but with power symbols. All my VCC, VCC1 (after one 0R), VCC2 (after other 0R) were connected together.
You should have separate symbol for each GND in your Power library. The net name the symbol will be connected to is hidden in pin name and not symbol name.

Yes I tried 2 differents things.
First, I tried to rename GND power signal
Second, I tried to used Global link and named it GND, GND_A, GND_B.
As a results, I still have the same problem.
All GND are linked together.

So either change your GND_A and GND_B to alternative ones provided by KiCad or look carefully at how the power symbols are made. Power symbols are connected via hidden labels. You need to replicate this in your own symbols.

Thank for the answer, I tried to rename the hidden pin but I still have the same problem.
As a answer, I used global link name such as P12VDC, M12VDC…
The problem disappears with that solution but I still have all the GND, GND_A and GND_B linked together.
Do you think it is possible to know if a component have included a script in its library ?

I will check if there are some hidden pins but I don’t think so.

Thanks I will try and come back to tell you if it worked.

Apparently you still have not figured it out after two weeks…

If you zip your project and upload it, then I’ll have a look at it.

I don’t use any scripts and really don’t understand the question.

I was curious and wonder if I understand the question/problem…

Thus, most likely my head’s in a cloud but, I wanted to see if a simple dumb circuit would produce similar results.

I placed some LDR’s, Grounds and VCC into a schematic. Annotated, Net-Listed and loaded the Netlist into PCB.

Results: All Grounds are properly named and isolated.

I placed two GND symbols and renamed one GND2.

I then highlighted the GND net.

Now note, this also highlights the GND2 Net as well as the GND net.

This shows why you should not simply rename power symbols as you may be unpleasantly surprised by the result.

Sorry, I can’t do that it is for work.
I think it a library problem with hidden pins.
I’ll figure it out.

I don’t understand either, i’ll try to unistall and reinstall kicad maybe i have a library problem. Thanks for your time.

I don’t think you have a library problem. I think you have renamed a GND pin - which is not enough to change how it is connected. GND_A and GND_B do not exist in the normal KiCad library, therefore I think you made them yourself and you have NOT changed the hidden labels.

I would try replacing your GND_A and GND_B connections with ones from the KiCad library like GNDA and GNDD and see if your problems go away.

I agree. I like many others have encountered this issue. Minor nuisance. Best is to copy then edit the symbol carefully with the symbol editor and make sure you change the name of the pin

Another approach is (first make a backup) and then open up your symbol file with a text editor. Search for the pin or search for GND with a search for “whole words only.”

You don’t have to upload the whole project.
You can delete most of the schematic and only leave some resistors or connectors as “placeholders” to attach your nets to. Something similar to what BlackCoffee posted.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.