Problem with schematic editor

For obscure reasons, I must have upset Kicad. I now have a lot of trouble/almost impossible to make a connection. Wires don’t seem to connect to devices or other wires. It had been working fine until I did SOMETHING wrong and I got into this problem.

did you turn off your grid ? Should be blue. It toggles off/on.


If you’re working in metric (mm) set the grid in the schematic editor to 1.2700mm.
If you’re working in imperial (inch), set the grid to 0.0500 inches.

Click anywhere on the schematic then press CTRL-A (select all).
Right click on any component and select “Align Items to Grid” in the context menu.

No, I didn’t turn off the grid (as far as I know) but somehow the drawing grid and the grid I used to add wires got mesed up. The select all, align to grid seemed to fix the problem but I really won’t know until I try the board layout, which will be a while as I can’t get physically to the components so I can properly select the footprints. Thank you for your help

Align to Grid does not really help when the grid for symbols and wires is set to the “wrong” spacing. This grid is quite important in KiCad. And the only sensible option is to set it to 1.27mm (equals 50mils).

There are several ways to set the grid (Toolbars, Menu’s, Hotkeys). One of the most common ways to get the grids into a *&^%$#@ situation is by pressing the n hotkey. This hotkey rotates between a few pre-selected grid settings.

Edit: “10mils” → “50mils”. Oopsie (ml9104 spotted this).

A very common problem is miss-hitting the M (for move) hotkey and hitting the N (switch to next grid) hotkey. This may have been your original problem.

Edit: I missed Paul’s comment on the same N key problem. :frowning_face:

Agreed, except it’s 50 mils, not 10. I always use 1.27/50 for schematic grid.

Simple Math, so others can understand in typical “Math-Equivalence” expression… I couldn’t resist