Problem with module print-out

Hi all,

I am designing some footprints in KiCAD, version: [Application: kicad
Version: 0.201412201901+5330~19~ubuntu14.04.1-product Release build].

I want to print one of my footprints out so that I can verify it against a real part. But the print system seems to be completely unuseable.

The basics are; if I print in black-and-white, it only prints the silkscreen layer. This happens whether I print to my laser printer or print to file (pdf). I thought it might be something to do with the black-and-white options (interpreting the other layers as white), so I tried to print in colour. This time it prints pretty much nothing at all, and again it doesn’t matter whether I print to paper or print to pdf - I get the same result.

Further detail:

First, here is a view of the module I want to print. It has 9 pads in the copper layer, 2 drill holes, some silkscreen and some drawing information:

I have tried to print it, using the following basic options:

If I select preview, this is what it initially thinks it is going to print for me:

When I select ‘Print’, another dialogue box appears and it provides another option to preview the printout:

If I select preview in this dialogue box, I am shown what actually ends up being printed:

As you can see, only the silkscreen layer is present. If I try in colour, even the silkscreen is not present in the preview. And this happenes regardless of whether I select my laser printer or if I select the print to file (pdf) option.

As another experiment I decided to drop my footprint onto a board and try to print it from the PCB layout software. Using that method you are able to individually select which layers to print. I made sure the copper and silkscreen layers were selected, but still it printed the silkscreen layer only.

Is anyone else experiencing this? Any advice?


If I drop the part onto a board and plot it, then it does plot all the layers. Unfortunately it seems like I must plot to a separate file, or page, for each layer. But this is much better than nothing.

I can’t get the print function to work at all.


The final workaround for this was to place my footprint onto a dummy board layout, select the plot function, select the layers of interest, and then set the output to gerber. Then I used a gerber viewer to load all the generated layers and print off the footprints.

If I try to skip a step and set ‘pdf’ as the plot output, then I found that the printed pads were slightly off, resulting in a significant error when I tried to marry up the real part to the printed output. This error was not introduced when I set the plot output to gerber.

So there’s lots of stuff not working properly here, but the most important one - the gerber plot - does work.