Problem with lines not on grid


I have several footprints for which the F.CrtYd lines have weird coordinates. They are not on the 0.01mm grid i’m using, and even when moving them i can’t bring them on grid.
I have to delete and redraw them…

Any guess ?


Some of the manufactures still make parts in weird American Imperial units; and that can affect the footprints.

If it is just the CrtYd layers that you are worried about, I wouldn’t spend my time putting them on any grid. Just take note that they do not overlap any other CrtYd parts on the same layer.


Well, i could live withit, but the KLC is rather strict and my upload did not pass through…
I MUST correct this.

I have several other footprints to rework, and i’m looking for a better solution than redrawing the bad lines.


That does not sound right. Usually the Coutyard-layers should be there to give you feedback for the pourpose of Component placement during Design.

Which Manufacturer are you using and what does he do with this Data? You could easily strip that data off by generating gerber files without the Coutyard layers. That should work.

1 Like

Hi Detzi,

You misunderstood me.

I’m trying to help the KICAD libray team and uploaded some of my footprints and packages to the KICAD Github.
There is a automatic checker called KLC (Kicad Library Check) and my footprint did not pass the check, because the F.CrtYd lines are not on a 0.01mm pitch !

Nothing to do with manufacturer and their needs.


You can run the scripts with the --fix option (locally)

You can also manually edit the properties of the lines. (press e while your mouse pointer is on top of the line.)

And in open gl you should be able to move the end points after selecting (left clicking) the line in question. (The end point will have a square or circle to show that you can drag it. It will snap to the selected grid.)

Hi René,

GREAT ! As a beginner, i never used Open GL and discovered it right now !
I looked a short video on Youtube and i’m amazed of what can now be done. Routing is much easier the the legacy mode !

I still have a LOT to learn… :frowning:

I corrected my lines using Open GL. Works fine now.
The Edit properties is much harder to use in this case.

Thanks a million !

Another option is to install KiCommand and run the command grid.

At the moment, it only works with drawsegments. But with your testing and feedback, I can improve it by adding the types of objects it can deal with.