Problem with footprint libraries


After a long pause in making some electronics I started again. Downloaded the latest KiCad software package and now I get the following error message when trying to associate the footprints of my devices on my schema

Look at the screen copy the strange path …

regards Rainer

It seems you have libs in your fp-lib-table that are not where kicad thinks they are. (Might they be left over from a previous install?)
Have a look in pcb_new: preferences->footprint library manager.

It could be that there are libs added to the project you opened. (Each project has a local fp-lib-table for project specific libs.)
You can test if this is the reason for the error message by creating a fresh project. Add a single symbol and then cvpcb. If you get the same error message the problem is the global fp-lib-table. Otherwise the problem is the library table of the project. (Or better: your project does miss some libs.)

If the problem is the global table, you can either try to find out what went wrong there or you make a fresh lib install.
For the former have a look at pcb_new preferences->footprint library manager and edit the entries such that they match your setup. (or remove offending libs and re add them with the library wizard.)

fresh install
For the official libs you have two options. Get them directly from github or have a local copy.
With the github setup you get always the newest footprints within the libs. You don’t have control over when you update. (Kicad downloads the libs to a temporary storage everytime it needs them.)

The first step in a fresh install would be to delete everything currently in your fp-lib-table.
After that you add the official libs you want (see below)
And after that you add your personal libs.

For the github setup open the kicad library wizard, select github as source (deselect save local copy to) and press next. in the next window select either all libs or only the libs you want. In the last page of the dialog select insert in global library table.

If you want to have more control when the libs are updated or when you don’t have a stable internet connection i would suggest a local setup. For how this could be done have a look at the tutorial by @bobc:


Hi @bobc,

Thank you very much. Now I can see the footprints again.

regards Rainer