Problem with Footprint Editor on KiCAD 5.1.4

Dear All,

I have a big problem this morning with KICAD 5.14, when i open the Footprint Editor, the layer “Edge Cuts” is grayed and not active!! In note it’s also for the layer “Margin”. It’s impossible to draw or modify outline of a component!!l.
With PCB all is OK, i see all layers.
Could you help me, i have to manage an important CAD project?
Best regards,

Why do you still use version 5.14? The current stable version is 7.0.<something>, Version 8.0 will be released in a few months.

The layer Edge.Cuts is disabled by intention. For the outline you can use F.CrtYd

Adding more ! doesn’t help anyone.

In older versions (such as V5) it was disabled for editing, but if you manually moved graphic lines to the Edge.Cuts layer (with a text editor) then they did stay there.

In Newer KiCad versions you can draw lines on the Edge.Cuts layer in a footprint, but the normal rules still apply: Edge.Cuts must be a closed shape with no overlaps or open ends. (Extra non-overlapping “holes” are allowed).

This suggest that yesterday it was working. I don’t think so. In V5 I have never seen possibility to edit Edge Cuts in footprint.

Yesterday was probably the first OP tried to draw a line on Edge.Cuts in a footprint :slight_smile:

5.1.4 is over four years old. The V5.1 .x series finished with 5.1.12, which had a lot of bug fixes over 5.1.4. If you really must work in V5, I would upgrade to 5.1.12.

If possible backup the old project and upgrade to current stable 7.0.8


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.