Problem with disabling visibility of layers in footprints

Hello everybody,

I just finished my first board in KiCad. Then I had to reinstall my OS. I installed exactly the same version of KiCad. Now I have the following problem with Pcbnew:

Disabling visibility for the layers F.Fab and F.Silkscreen has no effect on my self made footprints (dimensions are on F.Fab and REF** is on F.Silkscreen).

Take a look at the attached screen shot to get a clear picture of what the problem is.

Is there a workaround? Does somebody know this problem?

Thank you for your help.

Best regards,


Check the ‘Render’ tab to the right… not just the layer tab.
If you got REF**/VAL** (and not %R/%V in text fields) they will react only on the settings in the ‘Render’ tab for Reference and Value visibility.

Thank you. Problem resolved.

This has been changed in [2b6889bc] on 2016-04-20.

This is the sort of thing that needs to be in a proper changelog if its in the next stable release. Wading through GitHub history with cryptic comments is hard work for non-developers

I assume it might be. On the other hand, this might not be considered “big enough” to make it into the change log. Plus, the change log is available only after a new release is out.

Its a change to the API, maybe affecting 3rd party scripts, so I think it should be

Personally I consider it as a HUGE improvement to have the REF/VAL text vanish “as expected” when a layer is turned off. This has bugged me many times.

This change may be important for ‘oshpark’ & their new support of kicad board files.

1 Like

It makes sense to me also, but just document the change so that unexpected behaviour can be pinned down to an old release etc

Hmm… just checking the Visibles toggles on Version: (2016-06-19 BZR 6943, and I’d say it is close, but the controls are still not quite right.

The tick-boxes for F.Cu and B.Cu have no effect, but x.Paste and x.Mask etc work as expected.

I find that under Render Tab, Pads Front and Pads back do work, but if there is a label and tick for F.Cu, then that should work as expected ?