Problem running footprint editor: kicad Version: (5.0.0-rc2-35-gda6600525)


#1

I’m building kicad from latest source https://git.launchpad.net/kicad (master branch)

Everything builds and installs but when I try to open the footprint editor I’m getting an error:
“”"
Footprint library editor failed to load:
IO_ERROR: Failed to load kiface library “/usr/local/bin/_pcbnew.kiface”.

from kiway.cpp : KiFACE() line:185
“”"
When I looked that that file and line there seems to have been a historical problem but it appears to have been fixed. I’ve possibly build without a required lib but don’t think I got an error in the build process. I’ll add my version info in case it’s useful. I’m running OpenSUSE Tumbleweed so it might be later versions of things which are causing problems. The file that is causing the problem “/usr/local/bin/_pcbnew.kiface” is at that location so I’m not sure why it can’t load the file

-rwxr-xr-x 1 root root 237628208 May 27 19:48 /usr/local/bin/_pcbnew.kiface

Application: kicad
Version: (5.0.0-rc2-35-gda6600525), debug build
Libraries:
wxWidgets 3.0.4
libcurl/7.59.0 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.4 libpsl/0.20.1 (+libidn2/2.0.4) libssh/0.7.5/openssl/zlib nghttp2/1.31.1
Platform: Linux 4.16.6-1-default x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8) GTK+ 2.24
Boost: 1.66.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.59.0
Compiler: GCC 7.3.1 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=OFF
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=OFF


#2

Try running “ldconfig” as root.


#3

I had this, or a similar problem with this file and a few others a while ago. Copying the file manually from my build directory to /usr/local/bin solved the problem. No idea why

Edit: I was on a Ubuntu system. I think the install directory there is /usr/bin


#4

Working fine on Xenial

Application: kicad
Version: 5.0.0-rc2-unknown-81af2db~65~ubuntu16.04.1, release build
Libraries:
wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.13.0-43-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.58.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.47.0
Compiler: GCC 5.4.0 with C++ ABI 1009
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Upgrading now to 201805270834+da66005~65~ubuntu16.04.1


#5

I do not know Tumbleweed, but with Bionics, one or two months ago, I had problems and I’m go back, to Xenial.


#6

Thanks that fixed it, like you no idea why but problem solved.
thanks again