Problem loading `interactive html bom` plugin on OS X [SOLVED]

[SOLVED]
It was a stupid mistake on my part. I’m on a work computer and in addition to /Library/Application Support/kicad/scripting/plugins, there’s another Library location (that’s hidden by default) specifically for my user profile where kicad was looking…

I’ll leave this up just in case it’s helpful to anyone else in the future…

~ ~ ~ ~ ~ ~

Hi all,

I’m trying to use the interactive html bom plugin with kicad version 5.1.5-0-10_14 (details below) on os x 10.14.6 and I’m unable to see the plugin in the Tools > External Plugins... list after following the installation instructions and refreshing the list (and restarting kicad).

I have verified that my user account as write access to the /Library/Application Support/kicad/scripting/plugins path where I added the plugin folder. After searching through these forums, the only thing I can think of is that perhaps it’s a python version? It seems that I have version 3 installed and KICAD_SCRIPTING_PYTHON3=OFF in the build info.

$ which python
/opt/anaconda3/bin/python

So assuming that this is the issue, how would I redirect kicad to use python 2? Or would it make more sense to try and build it from scratch using python 3 (and if so, how do I go about doing so)?

Thanks,
-eric

Build info:
    Application: KiCad
    Version: (5.1.5-0-10_14), release build
    Libraries:
        wxWidgets 3.0.4
        libcurl/7.54.0 LibreSSL/2.6.5 zlib/1.2.11 nghttp2/1.24.1
    Platform: Mac OS X (Darwin 18.7.0 x86_64), 64 bit, Little endian, wxMac
    Build Info:
        wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
        Boost: 1.69.0
        OpenCASCADE Community Edition: 6.9.1
        Curl: 7.54.0
        Compiler: Clang 9.0.0 with C++ ABI 1002
    Build settings:
        USE_WX_GRAPHICS_CONTEXT=ON
        USE_WX_OVERLAY=ON
        KICAD_SCRIPTING=ON
        KICAD_SCRIPTING_MODULES=ON
        KICAD_SCRIPTING_PYTHON3=OFF
        KICAD_SCRIPTING_WXPYTHON=ON
        KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
        KICAD_SCRIPTING_ACTION_MENU=ON
        BUILD_GITHUB_PLUGIN=ON
        KICAD_USE_OCE=ON
        KICAD_USE_OCC=OFF
        KICAD_SPICE=ON

Both install locations listed in installation instruction have ~ prefix which means user’s home directory on unix/linux systems.

Ahh… of course! I should’ve realized that… I always thought of it as being the “top” level, but I guess that’s a consequence of always being the only user on systems I’ve worked with the command line on…