Problem installing libraries for KiCad 7 on Mac

Hello everyone,

I am struggling to resolve broken library pathways in my recent KiCad 7 installation. I have attempted to delete all old Kicad files, but the new software shows pathways to “legacy” libraries that don’t exist and I cannot figure out how to change them. I have read other posts on this forum about similar problems, but I am still unable to resolve the issue. Would someone with Mac experience please help me? I’m happy to pay you for your time. Thank you so much!


Read through this (long) thread and see if it helps:

Thank you so much for your reply - I am aware of this thread and have been trying everything I can to make the suggestions work for me… no luck thus far. I will post some screenshots to indicate where confusion arises for me. Thank you again!

I am using v7 on MacOS Ventura, so I might be able to help you with the library paths.
But, library management seems to be one of the most confusing aspects of KiCad.

Thank you so much!! And wow, yes, very confusing! KiCad developers should include a default option to overwrite all previous libraries because if you don’t know how to get rid of everything you are pretty stuck. Your suggestion solved my problem because you brought my attention to the end of the thread. Thank you!! What worked was to find and delete all instances of KiCad in BOTH my Library and my ~Library folders. When I did this, I was given the option to establish new library configurations during install… but only then. Otherwise, the software will install with a broken link that is very stubborn to fix (I couldn’t manage).

For other Mac users who have this issue, here’s the part of the thread that solved my issue:



I had the same problem:

  • After upgrading to v7, no more access to any component or footprint because of a directory error.
  • My configuration : Kicad 7.0.1 with Mac Os 13.2.1 on a 2018 MacBook Air

What worked:

  • Rename (or delete) the Kicad folders located in: Library/ApplicationSupport/Kicad and ~/Library/ApplicationSupport/Kicad
  • Rename (or delete) the Kicad folder located in: ~/Library/Preferences/Kicad/
  • Accept the default settings at first launch

Thank you all for your involvement in the KiCad project!

1 Like

Glad you got it working!

Yes, me too!! Thank you so much!!!

1 Like

There is a default option.
During the installation, there is a pop up asking about libraries. From memory, I think there are three alternatives. One has the word “Recommended” preceding it. If that is chosen, the Kicad libraries for that installation overwrite older libraries and create the required paths and all ends happily with the installation.

This is not explained well and people choose a different alternative because they consider, understandably so, that they already have the libraries, so why bother with another copy as well as their existing Kicad libraries.

To avoid this problem, and the resulting confusion, that section of the installation really needs clarifying. You are but one, of many, many users, on all three operating systems, who have been caught out.

I’m pleased it has ended well for you. :slightly_smiling_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.