Problem importing legacy .mod files


#1

Hi all,

I’m new to Kicad, and I’m trying to import my Eagle libraries to Kicad. I have seen that SnapEDA has a tool for that. i can succesfully tranform them into Kicad format. I can add the symbol, but when I try to import the footprint, the wizard doesn’t recognise the file (.mod), I have also tried to add the path manually indicating that it is a legacy footprint. I have downloaded a ATMEGA328P footprint from SnapEDA to ensure that the problem in not my Eagle model, it doesn’t work either.

I’m using Kicad 4.0.6, with Widnows 10.

Thank you ver much for your help !,


#2

Works for me (Windows 7 64, 4.0.2). Is there an error message?

Hopefully you watched the video https://www.snapeda.com/about/import/#KiCad


#3

Hi bobc,

thanks for your answer, yes I have seen that video and I have followed the steps (including downloading the same part and placing on the desktop, for considering all the possibilities). And the symbols imports perfectly, but in the footprint wizard, it doesn’t show the *.mod file, so I can’t click in it, it’s like the folder is empty. I have change to select only .mod files and even that way, it doesn’t show the file.


#4

After importing the part you may have to exit kicad altogether and then restart. I have noticed that I can’t see parts that I have recently saved to my personal .pretty library folder till I exit and restart.

But I have been able to remember the name I gave the part and enter it manually in the selection name box and it will find it even though it doesn’t show in the list.

hope that helps
dwight


#5

Hi every body. I saw this problem on kicad 4.0.6. and 4.0.5. I note this problem on windows 7 32 bits and windows 10 32 bits. I run kicad with administrator permissions and the problem is here yet. Restart kicad doest not work for me.
I have to test this on linux installation yet.

Best regards
Facundo.


#6

Hello there,

I recommend you to add the footprint library (.mod file) to your footprint library table (Go to KiCad, open Pcbnew, select Preferences and you’ll find the Footprint Libraries Manager) otherwise, KiCad will not be able to find the footprint. Please make sure to select the right library type in the footprint library table editor. You must select the “Legacy” so KiCad knows how to parse the file.

Configuring the footprint library table is fully documented in the the KiCad user’s guide: http://docs.kicad-pcb.org/stable/en/pcbnew.html#_managing_footprint_libraries_pretty_repositories

I did this process and I could add the .mod file perfectly.


#7

You should not need to do that with a correct Windows installation.
You should always put project files and custom libraries in your User space