Problem changing hole size in pcbnew

I just changed the hole size on 11 through-hole pin headers and connectors to all be 0.045". I modified the sizes using the Footprint Editor and saved them to a new library but with the same footprint name. Then, I reassigned the footprints using CvPcb, rebuilt the netlist, and read the netlist with pcbnew. The Exchange Footprint option was set to Change. The hole size changed on 8 of the connectors but did not change on 3 of them. I checked a bunch of stuff, library paths, looked at the model files to verify the new hole size, etc. Ran it again and again. The 3 connectors did not change. Finally, I ran Exchange Footprints with the old and new being the same footprint name. Then, the hole sizes changed. Very odd.

All 3 connectors are the same family and were created at the same time. I include a file from one of them. I am a newbie and could have done something wrong. But, it worked on 8 and not on 3. Anyone else seen this sort of thing?

KiCad version 4.0.6 running on Windows 10. Downloaded and installed about 2 weeks ago.

(module Phoenix_1725656_2pos (layer F.Cu) (tedit 5CCA32AF)
(tags “Phoenix Terminal”)
(fp_text reference J4 (at -4.445 -2.54) (layer F.SilkS)
(effects (font (size 1 1) (thickness 0.15)))
(fp_text value Screw_Terminal_1x02 (at 0.635 5.08) (layer F.Fab)
(effects (font (size 1 1) (thickness 0.15)))
(fp_line (start -3.175 3.81) (end -3.175 3.175) (layer F.SilkS) (width 0.15))
(fp_line (start -2.54 3.175) (end -2.54 3.81) (layer F.SilkS) (width 0.1524))
(fp_line (start 0 3.175) (end 0 3.81) (layer F.SilkS) (width 0.1524))
(fp_line (start 2.54 3.175) (end 2.54 3.81) (layer F.SilkS) (width 0.1524))
(fp_line (start 3.175 3.175) (end 3.175 3.81) (layer F.SilkS) (width 0.1524))
(fp_line (start -3.175 3.81) (end 3.175 3.81) (layer F.SilkS) (width 0.1524))
(fp_line (start 3.175 3.175) (end -3.175 3.175) (layer F.SilkS) (width 0.1524))
(fp_line (start -3.175 3.175) (end -3.175 -3.175) (layer F.SilkS) (width 0.1524))
(fp_line (start -3.175 -3.175) (end 3.175 -3.175) (layer F.SilkS) (width 0.1524))
(fp_line (start 3.175 3.175) (end 3.175 -3.175) (layer F.SilkS) (width 0.1524))
(fp_line (start 2.54 2.54) (end 2.54 3.175) (layer F.Fab) (width 0.1524))
(fp_line (start 0 2.54) (end 0 3.175) (layer F.Fab) (width 0.1524))
(fp_line (start -2.54 2.54) (end -2.54 3.175) (layer F.Fab) (width 0.1524))
(fp_line (start -2.794 2.54) (end 2.794 2.54) (layer F.Fab) (width 0.1524))
(fp_line (start -2.794 -3.175) (end -2.794 3.175) (layer F.Fab) (width 0.1524))
(fp_line (start 2.794 -3.175) (end 2.794 3.175) (layer F.Fab) (width 0.1524))
(fp_line (start -2.794 3.175) (end 2.794 3.175) (layer F.Fab) (width 0.1524))
(fp_line (start -2.794 -3.175) (end 2.794 -3.175) (layer F.Fab) (width 0.1524))
(pad 2 thru_hole circle (at 1.27 0) (size 2.032 2.032) (drill 1.143) (layers *.Cu *.Mask))
(pad 1 thru_hole circle (at -1.27 0) (size 2.032 2.032) (drill 1.143) (layers *.Cu *.Mask))

I don’t get this part.
Can you explain it better, different please?

Certainly. This seems like an obscure function to me. In pcbnew, right click on the part and at the bottom of the menu is Exchange Footprint. This is the menu with Move, Drag, Rotate, etc. There is the opportunity to name two footprints. It is almost like the Exchange Footprint option when reading the new netlist did not work and a manual operation using the “manual” version in the part menu did work.

I just noticed the Exchange Footprint option on the part menu is gone now that the new footprint took effect.

It’s quite different.
With the change footprint you can select any footprint included in your loaded libraries.

Reading the netlist you will change the current footprint with the footprint associated in the schematic. Or to be more precise, the footprint in the netlist.

By the way, why have you installed v4.0.6? If you do need version 4, install v4.0.7.
Both versions are quite obsolete. The most complete version is v5.1.2, and even v5.0 has a lot of improvements not present in any version 4.


I have the version offered from about two weeks ago. Where do I get the latest and most stable? I will get it and experiment. After noodling around some more with my version, there is definitely something flaky with the exchange footprint functionality. Again, please point me to the latest and greatest. Or, there MUST be a post about updating…

What operating system are you using?

Windows 10. When I do Help->About KiCad is sez “4.0.6”. The exe download from two weeks ago is a file named “kicad-5.1.0_1-x86_64.exe” I am thinking the file name is current and I have a 5.1.x version.The Help info is wrong? If so, I really appreciate your help in setting me straight. Maybe back to the footprint issue?

I just noticed the title of the project window also sez 4.0.6

I cannot test your version with windows. In the link above you can find v5.1.2 for windows.

That’s where I downloaded from. I will download again and re-install.

Got the latest version. Either I went through a time warp or had downloaded KiCad back in early 2017 and did not install the latest down load over it. Probably the later. Anyway, thank you so much for patiently getting me correctly set up. I now have 5.1.2 and my project did not blow up although the “rescue” steps were a little worrisome…

This might help with getting your project over to v5: Converting KiCad version 4 projects to version 5 (Remap a project)

And you might want to read this: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

1 Like

Thank you Rene. I took a quick look and I do have some work to do with the libraries and make everything consistent through the tool chain. These references are very helpful.

When you get back to modifying footprints and updating them on the board, you now use Update Footprints From Library (which does the somewhat bizarre exchange footprints with source and dest equal under the hood, but without exposing its foibles to the user).


There are many differences since 4.x I must go back to school at bit. Thanx for the heads up on the Update Footprints From Library. This looks like an easy way to batch edit footprints and update all at once. Which is what I was trying to do in the original post. Thank you for picking up it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.