Printing Image in the schematic

Hello, I am unable to print images in the schematic. I have a truth table in some pages added as Bitmap image and they don’t show in the printing, whatever physical printer or virtual/pdf I choose. I am using Windows 11 and KiCAD 6.07. Thanks for your help.

EDIT: Adding the OS and kiCAD version.

Have you tried exporting it as PDF and check if the image is shown?

1 Like

Yes, I tried to print to .pdf, and Export → Drawing to clipboard, they are not working. The preview to print also is not showing the bitmap. Thanks for your help.

Please upload the schematic, so we can investigate further.
You could also try File–>Plot–>to PDF (maybe that helps as workaround).

1 Like

Can you share your schematic? It seems very odd and I guess there is an easy solution :smiley:

Here is one
Sensor1.kicad_sch (121.2 KB)
page of the schematic, that table is an image

Hi @primer101

The drawing was produced using a 6.99 version.
You are using 6.0.7. Maybe that is the problem?

Hm. I can’t reproduce your issue with KiCAD 6.0.7 on Ubuntu 22.04.
Sensor1.pdf (81.6 KB)

@ekoeck
Neither could I reproduce the issue, but I’m on Mint which uses Ubuntu which is not the OPs Windows 11, hence my above comment.

I have never used the 6.99 version

This one works as workaround, thanks! But we need to investigate what happens with Print

I got different results on my system (v6.0.7 on Win10, and I think it’s really a v6.0.7-file with version-string 20211123):
original file (provided by primer101), no changes:

  • File->Export->Drawing to clipboard works fine, paste into pictureviewer gives expected view
  • printing works fine with real Brothe printer
  • printing works fine with virtual Microsoft Print To PDF driver
  • printing completely doesn’t works with virtual PDF printer: EDocPrintPro (normally my standard pdf-printer, but now not investigated further)

But:
Changing the worksheet-size gives unexpected results!

  • File–>Page settings–>Size: change from USLetter 8.5"x11" to DIN A4 210mmx297mm
  • now again try printing/exporting:
  • export to clipboard is still working fine (contrary to original Op description)
  • but printing gives a false positioned bitmap! (already in the print-preview-window - sometimes the bitmap overlaps the worksheet, sometimes it’s completely outside of the page)

@jmk / @ekoeck : could you test the changed file again?

Sensor1_size_A4.kicad_sch (126.5 KB)

Hmm… I can’t say that I recognize any unintentional changes. Print preview looks finde and PDF export as well. If there is still some issue maybe simply file a bug report and let the devs figure out what’s wrong.

@mf_ibfeew

The only differences are:
The border is expanded L to R approx. 1cm.
The border is contracted Top to bottom approx. 5mm
The drawing and image are shifted to the left (approx. 1.5cm) so the LH border of the image is now almost in line with the LH edge of the title block.
The position of the drawing with respect to the image has not changed.

This is printing with Epson 3700 Linux Mint 20.3

Weirdly I try opening both files without success …

image

image

but I don’t see anything strange on that line

Application: KiCad Schematic Editor (64-bit)

Version: (5.99.0-11119-g3269f45776), release build

Libraries:
	wxWidgets 3.1.5
	libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Jun 23 2021 09:00:14
	wxWidgets: 3.1.5 (wchar_t,STL containers)
	Boost: 1.75.0
	OCC: 7.5.0
	Curl: 7.74.0-DEV
	ngspice: 34
	Compiler: Visual C++ 1928 without C++ ABI

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

EDIT: Looking at my post I realized that somehow running Eeschema in standalone calls and old version (v5.99), opening the correct Eeschema solved my issue :no_mouth:

EDIT2: In a real printer, it printed correctly both times US_Letter and A4, but using PDFCreator to generate a PDF it did it correctly only as US_Letter, as A4, the bitmap was shifted out of frame.

US_Letter:

A4:

It will only open in 6.99 for me, no matter what I do.

If I write “Eeschema” it runs v5.99, if I write “Schematic Editor” the it runs the correct version, that is also my latest version, could it be that as your latest version is v6.99, that is the one that gets run ?

6.99 is only a couple of days old, so that must be the case.