Precedence of colliding field names for BOM generation with KiBOM

I’m generating my BOM with KiBOM.

The Description field is always taken from the component library, not from the description field present as part of the symbol properties in my schematic.

Is there a way how I can select which of those colliding description fields I can put into my BOM?
Is there a way how to declare precedence which field to use, when column names are colliding like that?

One more (bonus) question: empty Datasheet fields are filled with ~, and it seems I can’t make them just empty. Is this normal or is there an error?

I’m using KiCad nightly (updated today. Version: 6.99.0-1.20220807git51b905b.fc36). KiBOM taken from recent github: https://github.com/SchrodingersGat/KiBoM

You would probably be best posting these points as issues on the KiBom GitHub repo to ensure that people who contribute to it see it and respond as they may not all keep tabs on this forum.

Could at least try and summon @SchrodingersGat ?

Ah, I thought this is more of a KiCad issue, than one on KiBOM’s side, tbh.
With KiCad’s “native” options to create a BOM, and the fact in general, that a “Description” field is usually filled from the library, but sometimes exists in the symbol only.
Also, it’d be nice, if it’d be visible in the symbol properties, which fields are actually present, i.e. the properties in the table when opening the symbol properties, and all the fields filled from the library.

Having said that, I’d also like some sort of “collision handling” or “precedence handling” when it comes to property fields. For instance, I’d like “local” properties to overwrite things from the library, if a field is colliding – or have that be a selectable option, perhaps?

All that aside, I might just open up an issue at KiBOM’s github and perhaps peek into the code myself, etc.