PPA for KiCad 5.1 branch


#1

Few days ago KiCad 5.1.0-rc1 was announced.

I had release a new PPA for this version (for Ubuntu users) :
https://launchpad.net/~js-reynaud/+archive/ubuntu/kicad-5.1
So you can add this new repo to get advantage of this new version:

sudo add-apt-repository ppa:js-reynaud/kicad-5.1
sudo apt-get update
sudo apt install kicad

Please note that 5.1.0-rc1 mean release candidate. So some bugs/error… can still be there…


#2

There also seems to be 5.1 support from:
Source Package: kicad (5.1~rc1+dfsg1-1)
https://packages.debian.org/source/experimental/kicad
But I haven’t tried it myself.


#3

Hi @jsreynaud ,

Jean-Samuel, installing 5.1 with synaptic seems to overwrite 5.0.2. I have removed the kicad-nightly repos.

Could you check if I am wrong? Thanks!


#4

Look to be logical. 5.1 version is supposed to replace 5.0.


#5

Thanks Jean-Samuel,

At least I know I’m not doing things in the wrong way.
Anyway, as far as the 5.1 is a candidate release, I would have liked to have both versions at the same time without the need of compilation from sources.

I’m in the process of releasing several boards with 5.0.2 so I cannot be a 5.1 tester in this moment.


#6

Yes the 5.1.0 stable release should replace the 5.0.x stable releases. But the current 5.1.0-rc1 is a release candidate not a stable release. (It is more like a nightly build compiled for a specific commit.)


#7

Hi all Ubuntu PPA users

I have problems opening the Python console with the PPA build.
The bug report is here:
https://bugs.launchpad.net/kicad/+bug/1816462
Could any of you perhaps try opening the Python consolde in PCBnew and report your version (preferably on the bugreport) and if it works or not?
Please note this is mainly aimed at PPA 5.1 or PPA nightly users.

Thank you