Possible position problem in Kicad 8.0.0

I used hotkey E for pad properties on pad No.4. This was the result.
Grid is 50 mil. Grid origin is marked with red arrow.

New Properties Panel shows correct X & Y distance to pad 4 but Pad Properties window shows X = -600 and Y = -350. This seems to relate to a position I marked with a via (green arrow)

Can anyone offer an explanation?

Ignore the other pad number 4. That is another problem.

Could you attach the project?

There is no project. The above case was a demo. to answer a forum question.

This morning I started a new project. I placed three different footprints from the Kicad libraries and used a metric grid. I used the E hotkey on various pads with the same strange result.

The green arrows show the position of the Grid origin and the BGA pad used in this example.

By quick testing it looks like the Properties panel shows the location in the board while the Properties dialog shows the location inside the footprint, as it is placed in the footprint editor. The latter numbers aren’t changed when the footprint is rotated in the board, so it may look confusing at first.

And at second and third, especially as the numbers don’t change when the footprint is rotated about its axis.

Of the pad? What is the measurement of the distance of the pad with respect to?
X = - 39.64 mm Y = - 31.48 mm. The whole footprint is 4mm sq.

I tried another example below. The grid is 1mm. The results of pad 1 for the three pad footprint are shown.
The results for the five pad footprint are X = 20mm Y = 10mm in the LH panel & X = -49.53 mm
Y = -45.085 in the Pad Properties dialogue.

I’m still completely lost as to the reference point, in the Properties dialogue, to which these pads are measured.

It’s of course possible this is a bug, but this doesn’t happen to me with my own example. So, could you still attach the project?

1 Like

hello all,

I join the company :slight_smile:

The following image shows the positions of R1:

The second image shows the positions of pad 1:

This is a non sense. If needed I can post the project.


Application: KiCad x64 on x64

Version: 8.0.0, release build

wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 11 (build 22631), versione 64-bit, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 23 2024 02:24:15
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.7.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

Well, I already asked for an example project twice, so why you didn’t just attach it?


1 Like


another image. If the pad is at X = -90 and Y = 200, then the origin should be the center of the red circle at bottom, well outside the sheet:

I would be of the opinion of creating a bug report.

BTW, don’t mind the ERC arrows in the image. This will be the subject of another possible bug in another post that I’m preparing.


here it is.

fp-info-cache should contain the few self-made symbols and footprints, right?


Basetta canale sinistro.zip (519.5 KB)

OK. To me it looks like it’s a bug when the “display origin” is changed in Preferences → Origins & Axis. With the default “Page origin” it works like I described.

1 Like


may I fill a bug report now?


Yes, as long as it hasn’t been reported already and you can describe step by step how to reproduce it (and in this case, what causes it because we know something about the cause and you can try the different settings).

Test_4.zip (339.5 KB)

Seems I missed the action. :slightly_frowning_face:

My steps to produce the problem:

  • Create new project.
  • Open PCB Editor
  • Place a Kicad footprint
  • Select Grid Origin from Display Origin (only if this is not the current selection).
  • Place a Grid Origin Point
  • Highlight a pad
  • Press hotkey E
  • Compare Pad Position (X & Y) in the LH Pad Properties Panel to the Pad Position in the Pad Properties Window (dialogue).

The Pad Properties Panel shows correct position. The Pad Properties Window shows rubbish.

EDIT: same problem on Kicad 8.99

Application: KiCad PCB Editor x86_64 on x86_64

Version: 8.0.0-8.0.0-1~ubuntu22.04.1, release build

	wxWidgets 3.2.1
	FreeType 2.11.1
	HarfBuzz 2.7.4
	FontConfig 2.13.1
	libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.16

Platform: Linux Mint 21.3, 64 bit, Little endian, wxGTK, X11, cinnamon, x11

Build Info:
	Date: Feb 23 2024 14:30:25
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.6.3
	Curl: 7.81.0
	ngspice: 42
	Compiler: GCC 11.4.0 with C++ ABI 1016

Build settings:

The default is Page Origin. To use the Grid Origin the Display Origin must be changed.

ok, tomorrow I will prepare it.


I checked, as best I could, for a report on Gitlab. I couldn’t find any.

If you don’t wish to report, I will.

No issues yet created so I created one: https://gitlab.com/kicad/code/kicad/-/issues/17243

Footprint pads seem to be the only problem and this problem occurred for both Page and Grid Origins.


the issue is not affected by the presence of a grid origin or not, so I have prepared a detailed issue here:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.