Possible Bug ? Symbol Pin Name Text 5.99

I am creating a new symbol and I cannot get the pin names to appear. Experimentally I increased the size of one pin name to 100 and that enlarged the pin type text. I still cannot get the pin name to appear. See Cross_SW_0603

Bobs_Passive.kicad_sym (34.5 KB)

Application: KiCad (64-bit)

Version: (5.99.0-13185-g0dcbfa2b69), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Nov 9 2021 12:00:58
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

It’s a symbol property, not a pin property. All pins or none.

Thanks for responding but I do not understand your point. All four pins in this symbol have names and none of the names are visible.

However I have some further information:

  1. I noticed this issue today while running an earlier version; about 1 month old. I updated to the latest version and confirmed the same issue with that newest 5.99 version before posting.

  2. In the last 1-2 months I have made other symbols and had no issue with pin name visibility. So I am thinking…what is going on?

  3. I usually edit a copy of an old symbol to make a new one. In this instance I started with a resistor symbol which had no pin names. Just now I try-edited an IC symbol which already had pin names. For that symbol, the font size setting changes the font size of both the the pin name and the pin type. But anyway the pin names remain visible.

So I have characterized the issue a bit more, but it is still there.

UPDATE 2: My screen shot was from symbol editor. I notice that pin numbers are also invisible in symbol editor; not just pin names. But I after placing the symbol into a schematic I noticed that I could set pin names and numbers to visible in the schematic. So all is good in the schematic, but pin names and pin numbers remain invisible in symbol editor.

Open Symbol Properties in the Library Editor.


OK thanks. That works. My error; it is not a bug.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.