Plugins problem after update

hello,

just updated from 6.0.4 to 6.0.6; from now on I cannot handle plugins and already installed plugins seem to not work.

From the main window | Tools | Plugin management

I get this error:

Unable to load url repository

11:20:55: SSL connect error
11:20:55: Unable to load url repository

I verified the url in the browser and it works.

The two already installed plugins were visible in the list. I have uninstalled them and tried to reinstall, but I cannot access the repository due to the above error. Anyway the plugins where not working.

Thank you
Salvatore

any idea on this problem?

Windows 10 21H2. I have tried a SFC /SCANNOW but no problems were found.

Thank you
Salvatore

thank you for the reply Paul, I have something to add. Some days ago, after having posted my question, I was able to load the repository url (always in the main window, no eeschema and no pcbnew running) and so I have reinstalled three plugins and one theme. But I think that it’s not correct to say that, in my case, plugins are not loaded; they are loaded (I mean the installed plugins and themes); and today I cannot load the url repository again (SSL error), but installed stuff is visible.

This happens with KiCad 6.06 release. I have another computer with 6.0.4 still installed and this error doesn’t happen. Now I try to update to 6.0.6 to see what happens.

Salvatore

The computer with 6.0.4 is ok. After updating to 6.0.6 it is still ok. The other computer, with 6.0.6 as well, gives the SSL error, but at this point I think that the update doesn’t matter.

Moreover, the %APPDATA%\kicad\6.0 folder is synced between the two computers. I return back to the non working computer so I will be able to attach a screenshot of the problem.

Salvatore

Maybe a check for the network time protocol on the problematic pc will solve this SSL issue.

back on the non working computer. This is the problem. Even after syncing the %APPDATA%\kicad\6.0 (the two folders are equal), here it gives the erro, on the other computer it doesn’t.

Salvatore

That’s just a download error.
Are you able to access https://repository.kicad.org/repository.json in a browser on that computer?
Can you check your system proxy settings are configured correctly?

hello,

I’m back on the problematic computer. As a preliminary information, I’m using Firefox (latest version) on all my computers.

Are you able to access https://repository.kicad.org/repository.json in a
browser on that computer?

Yes, see firtst image.

Can you check your system proxy settings are configured correctly?

They are. See second image. Sorry, it’s in Italian; it says that I’m using system proxy settings, as is on all the other computers.

Proxy

Does KiCad install any system files regarding SSL that could be missing somewhere in the system folders?

Just to be sure, I’ve just tried again the “Plugin and content manager” and I get the same error.

Thank you.
Salvatore

No. KiCad uses Windows for ssl, nothing separate.

The proxy settings I am talking about are located in the Windows setting app under Network & Internet > Proxy

I ask because malware is known to change these settings from default which is Auto and would cause you problems here with kicad.

hello,

proxy is ok. It is in Italian, but it matches yours.

Salvatore

Though my system is Mac, thus different file system, this may help…

Background: Before I updated to v6.0.x, all my Plugins were working and had no problems with my custom folder locations.
Then, I updated my Mac and Kicad and lost all of the links so, my plugins were no longer accessible and I had similar url error plus headache. I removed an old link to GitHub and the URL problems went away but still, My plugins didn’t run.

After inspecting ‘this and that’, I discovered Kicad placed/added new Folders and locations. So, I reset my links as commonsense dictated (and, relocated My plugins) and, Bingo! All ‘My Custom Plugins’ and Kicad’s plugins came to life.

Screenshot shows the Folders and Path panel (after all is working) - some inspection of your system/etc may reveal a similar ‘discombobilation’

hello,

thank you for the reply.

I actually have three computers with KiCad 6.0.6 installed: Two PC and one notebook.

On two out of three, KiCad Plugin Manager is working perfectly: On the most powerful computer (Windows 11, I7 7700K) from which I’m actually writing this message and on the HP notebook (Windows 11, I5 8700). Troubles are on the oldest PC (Windows 10, Core 2 Duo). The common denominator is that all the three computers have the %APPDATA%\kicad\6.0 folder synced with a fourth folder with the same name residing on a networked NAS. It serves only for this purpose, but all the three computers use the local %APPDATA% folder when running. Of course, no more than one computer can run KiCad at the same time.

So, the most likely cause of the problem is that on the Windows 10 PC something regarding SSL has broken, but what?

Salvatore

Ok, I understand… That said:

• Is the folder Read/Write?
• I notice in the posted screenshot there are ‘spaces’ between words. Kicad/Python doesn’t play well with this or non-UTF8 characters…
• There’s a Hash in the .json extension (.json#) the first line. Is it supposed to be there?

Look into it…

You are pointing out completely irrelevant things and are only going to confuse the s.besso.
Python does not parse this json. This is in C++ domain. There is absolutely nothing wrong with that capture.

1 Like

I cannot answer to your question no. 2 and no. 3 because I don’t know.

Question no. 1: of course it is R/W. Any folder created in the %APPDATA% folder is R/W because it is created from the application’s installer.

Salvatore

I’m writing these replies from the problematic computer. This morning, after boot, I’ve run the sync program as I do everytime I have run KiCad on one of the other computers. Strangely the “Plugin manager” has worked fine; after this test I have closed KiCad. I point out that I haven’t made any change to the operating system nor to KiCad (apart the sync). After about thirty minutes I have tried again and blam! Again the error. Then I powered off the computer. I tried again now, while I’m writing this reply and again the error. This thing starts to puzzle me.

Salvatore

Most likely you’re correct. But,…

I might be pointing out “Completely irrelevant things” And, for sure, I left my Windows knowledge behind years ago. Nonetheless, my commonsense suggests looking into the ‘#’

Here’s a link to ‘#’ problem in Filenames on Windows10.… I’m not saying this is the problem but, user won’t know that it’s not the problem until investigation…

Oh, and, just because an Application can Create a Folder, does not mean that Write permissions are set to enable… If it were me, I’d delete the # and see what happens…

I’ll leave this topic alone…

ADD: Oops! forgot to include a screenshot (and, you can Google hashtag problems in Windows10 filenames for URL’s). Enough posts on net about this on Windows10

hello,

as the sync program accesses the %APPDATA%\KiCad\6.0 folder, it means that this folder has R/W permissions.

As I pointed out in my previous reply, this morning the “Plugin manager” worked as it should, but thirty minutes after not, with the same error. Very strange.

Regarding the # character, I’m not aware that this character could be illegal in the Windows world:

Illegal character

If it would, the operating system would start to scream as soon as you type it.

I have just tried on the other computer, and it works fine (Windows 11).

Salvatore

You couldn’t be anymore wrong about this… Google it and you’ll discover it is Not the System perse’, it’s the programs that use the filename under Windows and it’s especially the case for URL’s… I’m done. Good luck!