Plugins not working after upgrading to KiCad 8

Hi. I am using Ubuntu 22.04.4 LTS. Downloaded Kicad8 from ppa. Installed some plugins from the Plugin and Content Manager and none of them is working. The plugins are Interactive HTML Bom and Replicate Layout.
The plugins are downloaded to the folder ~/.local/share/kicad/8.0/3rdparty/plugins/. I can not run them from the PCB Editor. I do not see the icons and they are not available through the menu Tools-External Plugins.
If I open the plugin directory from the menu option Tools-External Plugins - Open Plugin Directory the folder opened is /.local/share/kicad/8.0/scripting/plugins. This is not the same folder where plugins are downloaded from the content manager. This folder is empty.
There is an environment variables called KICAD8_3RD_PARTY that points to /home/calu/.local/share/kicad/8.0/3rdparty/

Is this some issue with Kicad8? Does anyone have the same problem? Or did I do something wrong?
When I had Kicad7 the plugins worked fine.
I appreciate any help. Thank you.

You are probably running into this issue Ubuntu PPA 22.04 deb does not contain `pcbnew.py` (#52) · Issues · KiCad / KiCad Packaging / kicad-ubuntu-builder / KiCad Daily Package · GitLab

It is fixed already, you can wait for 8.0.1 or use the testing ppa
ppa:kicad/kicad-8.0-nightly

1 Like

Thank you. I installed the nightly ppa and it solved the problem.

Be careful with nightly, it’s not the same as testing. Nightly will be unstable and not backwards compatible with v8.

OK. Thank you for the warning. To be clear, I am using this one:

sudo add-apt-repository ppa:kicad/kicad-8.0-nightly

According to the download page this is the Testing Builds.
I understand is not the same as the stable version. When version 8.0.1 is out i will switch to that.

Yep, you are good, that is the testing ppa.

I had this same issue and resolved it without using a nightly version (which can break your project’s compatibility)

apt-get: plugins broken in 8.0.0
flatpak: plugins work in 8.0.0

I’m assuming I’m running into the same issue: I upgraded from KiCad 7 and now I can’t see any plug-ins from the PCB Editor after downloading plugins from Plugins and Content Manager. No files are found in /home/shane/.local/share/kicad/8.0/scripting/plugins where they should be. I tried adding a plugin directly to that directory and it did not show up in the PCB Editor. Running Ubuntu 22.04 LTS.

There was a problem with Ubuntu.

Download the “Testing Build” from the Kicad site. This will install 8.0.1-rc1 over 8.0.0.
8.0.1-rc1 is a minor release so it will not cause problems with existing libraries and projects.

This is now fixed in 8.0.1 which is released — and can be installed normally without any nightly builds or release candidates being needed.

1 Like

I just installed KiCAD 8 from PPA. About KiCAD claims I’m running Version: 8.0.1-8.0.1-1~ubuntu22.04.1, release build

And I’m running into this problem.

Project Manager → Plugin and Content manager.
Install various plugins. They show up in …/kicad/8.0/3rdparty/plugins/
Start PCB Editor on an existing board: No plug-ins on the tool bar along the top.
Tools → External Plugins: Nothing listed there.
Tools → External Plugins → Open Plugins Directory: opens …/kicad/8.0/scripting/plugins which is empty.
Close PCB Editor. Symlink …/scripting/plugins (link) to 3rdparty/plugins/ (directory)
Reopen PCB Editor: Still no plugins listed, as above.
Tools → External Plugins → Open Plugins Directory: opens …/kicad/8.0/scripting/plugins like before, but now the plugins show up (since it’s a symlink).

As for the “fix” linked from this issue, I do see pcbnew in /usr/lib/python3/dist-packages/pcbnew.py, NOT in /usr/local/lib as that issue claimed was the problem.

I have not yet tried installing the nightly build, but @squiggle claims that’s no longer necessary.

Anything else I should be looking at? Any other information I can provide to help figure out what I’m doing wrong?

Never mind, I found the problem.

I had installed the KiCAD 8 PPA, apt update’d, and installed kicad 8. But I didn’t do an apt update, so all the other kicad packages were still the old version.

Once I did sudo apt update && sudo apt dist-upgrade and restarted KiCAD, all my plug-ins show up now. (I undid the symlink thing from above before doing the upgrade.)

I hope this helps someone else who has this problem.

Spoke too soon. They’re gone again. I’m not sure exactly when they disappeared, I didn’t notice they were gone until I went to use one (exporting gerbers for fab.)

If you select Tools > Scripting Console from pcbnew, does it say this or something else?

Startup script executed: /home/username/.config/kicad/8.0/PyShell_pcbnew_startup.py
PyShell_pcbnew_startup.py
>>> 
>>> 

It says what you showed:

image

And, annoyingly, all the plugin icons are back this morning. rolls eyes If I see it again, I’ll try the scripting console thing and report back here. If I post here again, assume that it hasn’t happened to me again. (I’ll try to remember to come back and post as much, but my memory is pretty rubbish.)

1 Like

Dang it, Plug Ins are gone again.

image

It looks like my problem is unrelated to the scripting problem from earlier in this thread. :frowning:

Anything else I should be looking at?

Refreshing Plugins doesn’t change anything.

Opening the Plugins directory shows an empty directory in .../kicad/8.0/scripting/plugins/, NOT .../kicad/8.0/3rdparty/plugins/ which is where the plugins are actually installed. But I’m 90% sure this was the case before when plug-ins were working.

There are separate plugin directories for user plugins and ones installed from plugin manager, the latter go into .../3rdparty/plugins so what you in folders see is expected.

When your plugins disappear if you go to tools->preferences->action plugins in pcbnew, what do you see? Is the table empty? Is there a button with warning sign on the bottom? If it is there then copy paste the output of the window that pops up when you press it.