Plugins not working after Ubuntu Upgrade

Hi there,

apologies if this is an issue which has been resolved somewhere else. I’ve looked around for a solution pretty extensively, but haven’t found any so far. I do admit that me not finding one might be down to me not exactly knowing what search terms to use…

I recently upgraded my Ubuntu to 21.04, and after that, none of the PCBnew plugins I had installed previously were there any more. I tried putting them into every single folder where I suspected they might be found by Kicad, to no avail. The scripting Console is also not working, so I suspect it might be something with Python, but I’m kinda lost with what to look for.

Thanks for any help.
Simon Warst

Application: KiCad
Version: 5.1.10-88a1d61d58~88~ubuntu20.04.1, release build
Libraries:
wxWidgets 3.0.5
libcurl/7.74.0 OpenSSL/1.1.1j zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.43.0 librtmp/2.3
Platform: Linux 5.11.0-22-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.68.0
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

If you install plugins for yourself and not system-wide, you should install them into your home directory. ~/.config/kicad/scripting/plugins should work.

But the scripting console not working is a problem. You have some version mismatch: the KiCad version is for ubuntu20.04, not 21.04. Have you set the PPA apt sources list properly and updated KiCad?

2 Likes

Ah yes, that did the trick. I must have overlooked that. Feels pretty obvious in hindsight, so thanks for pointing it out.

1 Like