Plot to DXF not showing dimensions

HI all,

I put dimensions on my Cmts.User layer along with text items for fabrication information, and plotted the layer to DXF.

The text I put on the layer appears in the DXF, but the dimensions do not.

What am I doing wrong?

Glenn

Why do you assume it is you that is wrong?

I had a look at this in both V5.1.8 and in V5.99 and I did not see the measurements in either LibreCAD nor in FreeCAD V18.4, which confirms your findings.

Then I continued on Gitlab to see if there already was a bug report for this, and found:

And now I’m a bit confused.
I also do not trust neither LibreCAD nor FreeCAD much for dxf files generated by other applications.

Dimensions are (can / should be) special entities in the .DXF file format and now I’m not sure whether KiCad writes them wrong to the .DXF file, or the viewers I have interpret it wrong.

I also exported a few layers to .SVG, and that seems to “flatten” the dimension entities as normal graphics.

I always assume I’m wrong until I can prove I am right. For all I knew there’s a simple switch to enable them somewhere I didn’t look.

I don’t mind the dimensions being graphic objects instead of AutoCAD dimension objects. I’ve already placed them where i want them and they’re showing the correct lengths, so I’d rather not risk the data getting mistranslated,.

One thing I noticed trying to dimension in AutoCAD, the edge cuts line is shown as an outline 20 mil wide, with the true cut line being in the space between the two outlines. I’d have to do a 10mil offset of my edge cuts to create a reference point for my dimensions.

Is there a way to make the edge cut a single line where it should be rather than two lines on either side?

After some clicking, I discovered that ‘Un-Checking’ the box encircled in Red will enable correct importing of DXF into FreeCad and LibreOffice_Draw

Helpful screenshots below… (Libre Draw loaded them individually, not into same file)

2 Likes

That’s perfect! It even plots the edge cuts down the center line rather than outlined!

I’d never have considered that option.

Thank you so much!

Glenn

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.