Plot Schematic to PDF - Text Select


#1

When recently plotting as schematic to a PDF file, the text is no longer selectable/searchable within Acrobat reader. The problem appears to be new, because older schematic PDF plots have selectable text. I’m using the latest stable version of KiCad 4.0.7 in Windows 10. Anyone else experiencing this? Any help is greatly appreciated.

Brice


#2

How do you print to pdf? Do you use the print dialog plus some kicad external tool to convert to pdf or do you use the pdf generator found in the plot dialog?


#3

If I recall correctly, this issue was introduced with a code change between 4.0.6 and 4.0.7, but has been fixed for some time in the nightly builds. Relevant bug report https://bugs.launchpad.net/kicad/+bug/1710454


#4

To print a schematic to PDF:
File -> Plot -> Plot
Select the format to PDF


#5

I don’t have a ton of experience using the nightly builds. This function has always worked in the past. When is the next stable build scheduled to be released?


#6

The next stable release will be version 5. I think the first release candidate is expected to go public within a month or so.


#7

I just tried with 4.0.6 and it works ok. I think there was a bug fix for something else that broke it after 4.0.6 was released. (I could be wrong on that)

There isn’t really a schedule… maybe in the next few months, with fair winds and following seas.


#8

I believe it was actually removed in the 4.0.x series intentionally due to having a serious bug for which a fix could not be backported with reasonable effort. Don’t quote me on that though. In any case, it’ll be working fine in 5.0.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.