Please stop tracking

When I receive an email notification because of a new reply in a thread I’m subscribed to, and I click on a link, I get the following:

My question is not about how to whitelist this or other means about how to avoid this pop-up.

My question is, is can this forum please stop using this tracking behaviour?

Because now, in order to avoid using that I have to manually navigate to the forum thread.

And yes, I’m paranoid.

1 Like

I have turned off notifications in my preferences for everything except personal messages, and only those get forwarded to my e-mail address.

I do like to receive the email notifications, but without the additional tracking :sunglasses:

Hello, another paranoid person here! I asked this same question about 2-3 years ago. Because this forum isn’t a fully custom built site by/for KiCad, it and the notification service comes “as-is”.

1 Like

It’s not a feature of the forum software.

It’s just been configured to use SparkPost as a smtp relay, since most server hosts forbid sending email yourself not to mention other issues with spam

SparkPost probably has a setting to disable tracking link metrics @ChrisGammell

Thanks for clarifying the issue.@marekr

1 Like

Hello! @marekr is correct, we use Sparkpost for sending out emails (we used to use Mailchimp) and that is the default domain. Seeing as I never look at the analytics, I just turned it off (the “SMTP tracking” setting in Sparkpost). Please let me know if this produces the intended behavior, which I think should be the direct links to the forum posts.

Thanks for bringing this to our attention!


Yes, no warnings anymore from ublock origin. Thank you for resolving this matter. :+1:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.