Placement of symbol name in symbol editor is different to schematic

i created an new component. If I place the symbolname in the symbol editor like shown in the left picture its placed in the schematic on anoter place. Is this an bug? I tried for hours to find an answer why its not the same
place. Can anybody help me?

Uncheck “Automatically place symbol fields”.


Thanks, this works fine. I would have never ever found this checkbox if you hadn’t told me.

1 Like

The auto placement is necessary to be able to rotate or mirror symbols and have a somewhat nice result from the get go.
Sadly kicad also uses the auto placer if the symbol is not manipulated in such a manner. I suggested to change this over on the bugtracker:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.