Pinning KiCad to the KDE taskbar

Probably not directly a KiCad issue. If I pin KiCad stable to the taskbar, it becomes nightly.
Any KDE people here having the same issue?
Animated gif below:

Dragging the proper .desktop file from /usr/share/applications/ to the taskbar is a workaround to get the stable version in the taskbar.

I’m guessing the launcher doesn’t use the full path of the executable so you get whichever KiCad is first in the search path. You can edit the launcher to fix that.

I remember editing paths of individual icons in the taskbar before, but this option is not any more available through the context menu in 22.04 /KDE Plasma 5.24.6.
Through the terminal I can launch kicad or kicad-nightly and get the respective application.

In that case it’s probably a system launcher that came with the nightly package that cannot be edited by you. Probably the most recently installed package wins. You should manually select the launcher like you did.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.