PCBNew stops identifying track for net(s) after restart

Hi all,

Tried to search around for this but didn’t find any answer, or I’m just not using the proper terms.
I’m starting with my first PCB’s so errors are expected, still this seems a odd behavior.

I’ve made this simple PCB and because it will be milled in a CNC I kept most in just the bottom layer.
Still I had to use some vias to the top and it was all fine and properly detected by Kicad.
I restarted the machine opened the PCB again and now it doesn’t detect it anymore. Tracks and vias are there but it still doesn’t detect it.

Screenshot: http://imgur.com/a/j0tP6

Is there any reason why it was detecting it fine before and stopped after I restarts the Kicad?
(Using Kicad 4…0.6 for linux)


Switch your pads into outline mode (a button in the toolbar to the left) and then check the tracks endpoints on those pads… I bet they aren’t snapped to the pads centers.

Check your setting in


for Magnetic Pads/Tracks.

Thanks for the hints.
They seem to be snapped to the center.

(The larger pads are just some helper pads I found to make them bigger for milling but the connection is still
done by the vias.

I check the preferences and both were set to “when creating tracks” I have changed both (pads/tracks) to be always magnetic.

Ok seems I fixed it.
It’s something with the pad, as long as I don’t set it’s net as GND it works fine.

So I did the routing using vias and after added these pads on top and set them to be on bottom layer only.