PCBnew shuts down when deleting component

Hi, I just installed KK on win10 details below:

Application: KiCad
Version: (5.1.4)-1, release build
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:

I pulled in an existing design done with same version KK on Win7, and changed my footprints and track colours over between top and bottom Cu. This left an SOT23 - 5 base in the wrong colours on my screen, even after changing them in footprint editor after which they were correct. When I tried to delete the base, PCBnew shut down. Tried again and same issue PCBnew shut down.
The problem was solved eventually, the base was locked. After unlocking it was removable and replaceable with the changed colours. If I lock it again, deleting it shuts the program down.
Is this reportable as a bug?

You might want to update to 5.1.5. There was a bug in 5.1.4 where kicad crashed instead of showing the conformation dialog when interacting with locked elements. I am not even sure if 5.1.4 was ever officially released. (i confused 5.1.3 with 5.1.4. 5.1.4 was the one that got released as a replacement for 5.1.3 before the latter ever got announced.)

Thanks @Rene_Poschl

I will try 5.1.5. I only installed 5.1.4 earlier this month, but such is the progress of this project!

5.1.5 was released in november. Which means you either installed or at least downloaded it back then. (Or you used a non-standard source for your packages)

1 Like

Thanks again for your help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.