PCBnew print function includes invisible text

So in my PCB I have moved all ref.des. and value fields of my stitching_via footprint way off above the PCB outline. I do this because even though they’re set invisible, they show with a grey color if the correct layer is on.

In this first picture, you can see all ref.des. for all my stiching vias being sown even though they’re “invisible”

In this second picture, I preview a print of layer F.Mask and Edge.Cuts. So I don’t include any of the layers where ref.des. or value are drawn (F.Silk and F.Fab. I believe)

The scaling option is set to “Fit to page”, and you can clearly see that the ref.des. or value text is tried fitted, even though it doesn’t show.

Can I make the print-function ignore completely text that is not part of the layer it is printing? I would also wish for, that even though I print F.Silk at some point, I don’t want the “invisible” text to be included then either.

Might it be that you have the “show hidden text” setting enabled in the render tab?
(this would explain why they are shown as gray even thought they are set as invisible.)

Disabling this might not fit the fit to page option. That could be a completely different problem.

This may be a side effect of the fix for this bug

Please raise this as a new bug

Thanks for reminding me about that option “Show hidden text”! Always thought it was a humorous sounding option, but I see the point of it. All though I would like to see a “Hide visible text” option to accompany it.

Unfortunately, un-checking this option did not fix the print-issue.

But it should allow you to move the text back to where it belongs. Which will at least hide the bug from you. (As stated above these are two different issues.)

Good point, I’ll do it

I will do it. There are a couple more to be raised from earlier posts I made.

I’m not able to select hidden text as a group, both in OpenGL and default. I can however move them individually. When selcting them as a group in “default” rendering I tick all the boxes including the “include items on invisible layers” (even though I know it’s not for hidden text).

Edit: Never mind, I fixed it with text replacing in a text editor

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.