Pcbnew not showing components, just ratsnest


#1

Hello,

I am using a Mac running OS X 10.12.6 and KiCad 5.0.2-5. I have a problem, as follows. I have a very large circuit with about 930 parts. Most of the parts are 11 instances of one circuit. I have the schematics nearly completed so I thought that I would try a layout.

I annotated the schematic, ran the debugger on it (there were 7 errors, some due to not-yet-connected signal lines; to be corrected) generated a netlist and opened Pcbnew. That is when the problem showed up.

In Pcbnew I had an identical collection of parts for each instance of the one circuit, and some other collections, one for each section of the schematic (one collection per page). The full ratsnest also appeared. So far so good.

When I tried to select one component to start to lay out the circuit, all the components except the one selected disappeared. The ratsnest still showed, but there were no components showing. I if I selected an area of the ratsnest, the components in that area would show, but only until I tried to select one.

I cannot use KiCad this way I have used KiCad for years on smaller circuits but never on a hierarchical one and never one with this many parts.

Have I run into a bug? Has anyone seen this before? If so, how do I fix it?

This is a disaster for me as I have to get the circuit laid out very quickly.

Suggestions?

Best regards,

Peter


#2

I gave your post a like so that it will increase your probability of adding a screen-grab.

Creating a NetList is no longer the recommended way to proceed from schematic to board layout. Instead, in PcbNew, under the main menu select: “Tools/ Update PCB from Schematic…”

Then click on the “Update PCB” button.


#3

On the right side of pcb new there is the layer and items visibility selector.
Make sure you have footprints and also pads selected as visible in it.


#4

Oh and in the layer selection the respective copper layer and also the layer that holds your part outline (typically the fab layer)


#5

Thank you for your suggestions, gentlemen. And thank you for the “like”.

Sprig, I tried using “Tools->Update PCB from Schematic” without success. The same thin happened again.

Rene, All of those (and more) were already selected. Jus to be sure, I unselected them and then re-selected them. It didn’t change the situation.

So I tried a much smaller project that also was a hierarchical project consisting of four replicas of one op amp with four resistors and a header. It worked fine last weekend and still works today. Just to check for sensitivity to missing footprints, I removed the footprint for the header. It produced four errors for the missing footprint but the layout still appeared fine in Pcbnew, although missing the four headers of course.

It looks to be a size issue. My next test is to reduce my big project to see if I can get a smaller version working but with all of the same components, just fewer of them. That will tell me if it is strictly a size issue. I’ll report back.

Best regards,

Peter


#6

Hello,

I reduced the large project to just two of the replicated circuits, not 11 as the project requires, and all the same single-sheet schematics that I had before. So now the BoM and footprints list have exactly the same types, values and footprints as the large project but just not as many of them.

It appears to work just fine.

This is not good news. It suggests to me that KiCad 5.0.2-5 has a size issue.

I will now increase the size of the stripped-down but working project to see at what point KiCad’s Pcbnew barfs, and report back.

Any other suggestions would be gratefully received.

Best regards,

Peter


#7

On some older Macintosh computers, complex renders do run out of memory and the Mac OpenGL implementation doesn’t report its errors nicely, so we don’t always know when it happens. Do you see the same issue when you switch to “Modern Canvas (Fallback)” under preferences?


#8

Hello Seth_h,

It appears that you were absolutely right. I bought a new Mac Air (16 Gbytes RAM, 1.5Tbyte disc) and the problem went away. My project makes 10 copies of one part of my circuit and that seems to work moderately well on the new computer, and won’t work on the old one (older Mac Air, 4 Gbytes of RAM, 256 Gbyte disc). Thanks for the “heads-up”.

Best regards,

Peter