PCBNew not show pads unless object clicked

Hi,

I recently upgraded to the latest nightly build of KiCad. Here is the version information:

Application: KiCad

Version: (5.99.0-9773-gf428ce03f2), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.74.0 OpenSSL/1.1.1k zlib/1.2.11 nghttp2/1.41.0

Platform: Linux 5.4.97-gentoo x86_64, 64 bit, Little endian, wxGTK, , tty

Build Info:
Date: Mar 22 2021 18:30:17
wxWidgets: 3.1.5 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.75.0
Curl: 7.74.0
ngspice: 33
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_EGL=ON
KICAD_SPICE=ON

All of the footprints show up in pcbnew but none of the pads appear unless I click on the part. Here is a screenshot of the problem:

Any help that you can give me will be greatly appreciated.

Thank,
Tim

Pcb Editor / Appearance Manager / Objects / Pads Click on the closed eye to make the pads visible.

Some other things:
Making a screenshot of a small window is easier for internet (both storage space, bandwidth, and zooming on this forum.

Version info is better copied & pasted as text.

Well that was stupid of me. I didn’t even notice that. Thanks a lot.

Well, at least he did provide the full window instead of clipping out only the footprints in the board view. Otherwise it wouldn’t have been as easy a fix to notice that he had pad visibility turned off. But, yeah. I agree that he probably should have resized the window smaller like you did.

There was a similar post recently (weeks)
Just the text that the pads are only shown when a footprint is selected would have been enough for me (in this particular case).

But I do appreciate the effort taken for trying to give all relevant information. Nitpicking on details and forgetting the overall view is a bit of a recurring issue for me.

1 Like