PCBNew Memory Error

I have a board last revised in 2016, with the following PCBNew version line in the .kicad_pcb file:

(kicad_pcb (version 4) (host pcbnew “(2016-03-29 BZR 6654, Git 67b4ba0)-product”)

I have been running nightly kicad-r11234.1685af842-x86_64 on Win10. The project and schematic opens fine (sch lib migration works fine), but opening the .kicad_pcb in PCBNew gives this error:

I figured it was a nightly issue (the price I pay for playing with new features), so I moved to the latest nightly kicad-r12334.03e787ef2-i686 and found the same issue. However, opening the project on MacOS using 6.0.0-rc1-dev-634-gb5e3f6406 works fine.

I feel like there may be some known migration issue I am missing, any thoughts? This is on Win10 with 12GB of RAM, and the error pops up immediately after the PCBNew window opens with a black canvas.

Here are some self-evident questions:

  • can you post the board file or the project here?
  • does the same KiCad work with other boards?

This sounds more like a system error than a KiCad error.

You are correct, I should have mentioned that first:

Unfortunately, I can’t post the project here as it’s commercial and propriety. I can say that it is a round shaped, eight layer board, with large fanout BGAs and lots of differential pair routing. It pretty busy, with a high component count.

Also, I have verified Kicad works on an array of other boards. I just updated another design yesterday running through the whole schematic, layout, create gerbers and off to quote process without any issues.

In summary, it is only this one PCBNew project that has an issue across multiple 5.1(?) nightlies that otherwise work fine on other projects (about 6 projects). The board opens fine in MacOS.

I tried opening and re-saving on the MacOS side, then copying project back to Win10, but got the same result.


I bet it’s a graphics hardware/driver problem. What do you have in your machine? Do you have the latest driver?

This is saying that your video card has run out of memory. You can try upgrading your video card drivers or you can use fallback mode.

1 Like

Ah! Thanks @Seth_h and @eelik, you are correct. Switching to fallback resolved the issue!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.