PCBNew Mac - Tracks Not showing

I’m currently having problems with tracks not displaying on two out of three machines.

All are Macs running Big Sur.

  1. KiCad 5.1.8 on 2019 MacBook Pro - tracks do not display
  2. KiCad 5.1.7 on Mid 2015 MacBook Pro - tracks do not display
  3. KiCad 5.1.5 on Mid 2016 MacBook - Tracks present.

The design has been created by our resident EE and I have downloaded the latest from our GitHub repository so all three machines are consistent in terms of the schematic and PCB layout files. I have event deleted the directories and recloned the repository and symbol libraries to make sure all three machines are consistent.

I have opened one of my designs and this works fine on one of the failing machines (i.e. tracks are showing on my design).

I’m at a loss as to how I can diagnose the problem and would appreciate some help.

Thanks in advance,

Well we are flying blind without a screenshot, so we really can only give generic advice. My guess is that the older machine is using the legacy toolset which does not respect the view options of the new toolset. The view options are part of the project specific settings which could explain why you see tracks in your project.

Make sure the visibility options are set such that the tracks are shown. This means the layer needs to be enabled in the right sidebar (there is a tickmark next to each layer name). Check that the item tab of this does not disable tracks (not sure if this was an option in 5.1.x)

Also make sure the outline mode is disabled (left toolbar). It could also be that you are in high contrast mode (left toolbar again) which desaturates certain layers (can lead to not seeing these if the colours are chosen badly).

1 Like

Check that the item tab of this does not disable tracks

You hit it on the head - tracks were disabled in the Items tab. FYI, Items is a Tab in the layers manager on the right hand toolbar.

Thank you for your time, it is much appreciated.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.