PCBnew loses track of cursor location - Windows 10

When I upgraded to 5.1.9 I got an issue where after certain commands the cursor location no longer references where it is on the layout. That is, if I click on a graphics of an item it won’t select it, it will select nothing (way off) or a component nowhere near the graphic I am pointing at. Essentially the display is getting out of sync with where it thinks it is pointing to in the database. If I simply do a “Zoom to fit” they get synced up again and I can zoom back to where I’m working, all is restored.

This happens reliably on first start, with a ^Z undo or a ground plane redraw, but other times I can’t predict reliably. This is tough to describe, so fear there may be something about this in the forums and I’m not using the right search term. This is weird enough if it was a general problem I’m sure I’d see more posts.

I’m running standard Windows 10 and noticed it first on 5.1.9. I’m using the legacy toolset. I should (and will) upgrade to 5.1.10 soon, but there isn’t anything in the release notes about this issue I can tell. Any hints would be greatly appreciated.


Check the settings in your preferences; I had something similar happen and it was just a settings issue.

Thanks Sprig, that gives me hope. I duplicated your settings exactly, restarted, but still have the issue here. I’ll do more tinkering in that area though if it worked for you. I’ll post if I have success.


Check if the issue happens in modern toolset, legacy can have bugs because it’s not used much.

Qu1ck: Good point too. I tried the modern tool set quite a while back and didn’t warm up to it. My boards are simpler and I really care about aesthetics, so didn’t like the automatic pushing around. I probably should just get used to using the modern toolset. Calling it legacy is probably a strong hint it may go away soon.


Oh it’s already gone in 5.99.
You can disable automatic pushing in interactive router settings. Just set it to collision mode so it highlights when something is too close to some other thing.

Qu1ck: OK thanks for the push (OK, bad pun). I found the setting to disable automatic shove for the modern toolset and get to keep the level of control I had before. Very nice. I should have realized they never would have removed that level of control even with the new toolset, just made it an option.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.