PCBnew layer colors not saved in V5.0.1

Hi. Just noticed a few oddities about pcbnew that are unlike V4.0.x.

Sometimes when I change the copper layer colours to the way I like them, the changes are lost after a system re-start. This seems to be a random thing as it will be fine all day then change the next time PCBnew is opened, and other times it will be fine for a few days.

I just finished a new RF PCB and with zones filled on the top earth plane which is pretty much all of the board, the silk screen is invisible except for in the spaces around through pin or isolated pads.

When I tried to add dimensions, the dimension tool completely covers the lines I am trying to measure to on the Edge Cuts layer. On V4.x.x it was transparent so the destination could be seen through the dimension line.

I am not sure if this is just the way V5.x.x is or if it is a bug, or my installation.

Wish list:

Allow the drawing width for dimension, edge cuts and track sizes to be pre-set in the PCBnew start up file, or better still in the KiCad initial page file, so that these can all be carried over to new designs.

Still a great job though.

I can’t test v5.0.1 but in v5.0.2 the colors are saved in the right way.

If you are now in the F11-modern toolset maybe you need to assign different transparency values to the colour of each layer.
If you select the silkscreen layer, is the silkscreen on top of everything then?

Up until now, I was wondering why my PCBs where looking different on the screen (as if there was too much color, a bit of a vingate look), I just realized that in v4.7 (because I went to check how measurement tool was working) that all layers had some transparency per default, in new v5.0.2 all layers are have no transparency defined.

Just double-click on the layer color square (or right click and then “Change layer color…”) and set the transparency to something lower (95% did it for me, maybe 90%), it is the same case with the annotate tool, it uses the default settings of the layer where you are annotating (Dwgs.User, Cmts.User, etc), just set the transparency in the desired layer to a lower value.

If you have copper zones and they are covering everything, it may be because you have currently selected the copper layer and the it comes automatically on top of all other layers, if you click/select the silkscreen layer, now the silkscreen should be on top of all the other stuff.
F.Cu Selected:

F.SilkS Selected:

@pedro Thanks for that, this is different from V4 and previous, the last selected layer is on top. Selecting Silk screen does put it to the top. For some reason the colours have stayed fixed for several days now - must be me.
@der.ule That seems to be the problem thanks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.