PCBNew - global pads clearance not working?

In PCBNew, when I set the global mask clearance for pads (Dimensions > Pads Mask Clearance), whatever values I put in are shown as changing the pad clearances appropriately in OpenGL view. However in Default view, the pad clearances never change. All pads are set to 0 locally, so they should be following the global settings (and do in OpenGL).

Photo example attached, both taken from the same spot in the same board. Clearance set to 2mil, minimum dam set to 3mil. KiCad is the latest version, 4.0.7:

Am I missing something, or doing something wrong?

IMHO, the legacy canvas never showed the solder mask clearance… what you see is the net-clearance around the pads. If I remember correctly the only place to see soldermask clearances was in the 3D viewer, with the odd behavior, that the 3D viewer in the footprint editor always took the setting from PCBnew and not what was set in the footprints… :wink:

Ah you’re right, I have my net clearance set to 6mil and those match. Can’t believe I didn’t notice that - thanks for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.