PCBNew Filled Zones - Some pads are not getting connected via thermals

I am creating a Filled Zone to VCC on the top layer. Most of the VCC pads are connecting but some are not. Is there a reason why and how can this be fixed?

I would like to post an image, but I’m not allowed yet.

h ttp://s22.postimg.org/o9y7cmfdt/Thermal_Missing.jpg

Probably not enough space. The thermals only connect at angles of ±45° and ±135°

Which parameters can I edit to make them work? I was able to manually draw a trace, but seems like a hack.

You can

a) play with the clearance settings of the hole zone (probably not ideal)
b) try per-pad settings

In your case the problem is with the pad keepouts interfering with the thermal spokes. The obvious solutions are:
(1) consider reducing the pad clearance to allow space for the spokes - put the mouse over the pad and press ‘E’ to get the pad editor; this is not necessarily the best option
(2) draw tracks as you’ve already done