PCBnew feels strange


#1

Hi,

How can put pcbnew Modern ToolSet (Accelerated) looking like the legacy?

Now looks like:
pcb

Since is in this state can’t fill the zones right.

I’m using Kicad 5.0.2-bee76a0~70~ubuntu18.04.1, release build in Linux Mint

Could someone help?


#2

Have you used the left hand toolbar zone fill buttons? Filling works all right anyways, you just don’t see it in this hatched outline mode.


#3

Depends on what you mean. Getting zones filled is done with shortcut “b”. If you selected filled view mode in the left toolbar then you will see the zones as filled. (As already hinted at by @eelik)

However you will not get the same look as in legacy as modern uses a different rendering paradigm (legacy uses xor rendering while modern uses transparency based layered rendering. By default transparency is turned off for all layers this can be changed by leftclicking on the colored field next to the layer name -> change colour.)


#4

Have this problem in two projects, if open other this doesn’t happens.

When do “DRC” the results is the following:
3d%20render


#5

It’s possible that a zone isn’t filled until you fill it manually, either by hotkey B or from a menu. Running DRC may, depending of the selected option, refill zones.


#6

@jneiva

The behavior explained by @eelik is the normal behavior in kicad. One needs to manually refill zones for changes made on anything else to take affect on them. (Recalculating zones is very expensive computationally. This is why it is only done on user input as it would otherwise slow down kicad to be practically unusable for more complex projects.)

The behavior you see could be explained if the zone was unable to fill when drawn originally.
Zones need a connection to a pad of the correct net to be able to fill. This is because kicad does not allow isolated areas in zones and removes them immediately. (Isolated zone areas are generally a bad idea for everyone concerned about EMC.)
If you move the pad into the zone area after drawing the zone then you need to refill manually. The same is true if you have a zone on a layer without pads and use vias to connect the pads to that zone. You will only be able to fill the zone after the first such via is added.