PCBnew fails to connect all components from the netlist

I have a schematic done and when importing it into PCBnew, most is read, but I’m having problems with relays. It seems the relays in the relay lib have an issue that prevents them from being connected to other components. The pins do display the blue NC cross. It’s really the relays, cause when I added some resistors the other components were properly routed according to the newly generated netlist. The connections are listed in the netlist, so the issue is really with the relay lib. Kicad is 4.0.6 on Funtoo (Gentoo). What’s going wrong? Is there another relay lib I’ve missed so far? (I’m aware of 2 more, but these are 1) small and 2) do not have the relay outline I need/use)


Without giving the exact component you have trouble with we can not help you.

It’s effectively every relay in the relay library:
(library (logical relays)
(uri /usr/share/kicad/library/relays.lib))

I’ve used this one in particular, but I did try others too:
(comp (ref RL1)
(value DV)
(footprint relay:relay-351)
(libsource (lib relays) (part FINDER-40.52))
(sheetpath (names /) (tstamps /))
(tstamp 5958D72E))

If you want I can post the entire project via Google Drive as zip file.

did you create the relay footprint your self?
There is no lib called relay in the official library. Only Relays_THT and Relays_SMD.

What are the pin numbers you used in your relay footprint? They should be A1,A2,11,12,14,21,22 and 24.

There are other symbols in the lib. Some of them use the numbers 1, …, 10 for the pins. Example: AZ850-x or IM00. But these two have a different pin ordering. (Different pin numbers mean something different) So choose the symbol that fits your footprint. (If there is no such symbol create your own.)

If i use the footprint for which the symbol has been designed (Relays_THT:Relay_DPDT_Finder_40.52) it works.


Here is the zip file for the project:

You’re right, the lib is not standard but I had it for so long I thought it was. It’s from a 3rd party but I can’t recall where I got it from. I may have to abandon those perhaps, if the standard libs offer the correct relay. Thanks anyway!

You don’t necessary need to abandon your footprint lib. You need to ensure that the pin numbers of the symbol you use agree with the pad numbers of the footprint you use.

The finder relay is a lot larger than the footprint you used.

I would guess it is an eagle lib. >Value is suspicious.

1 Like

That might be the key, 'cause I don’t think that’s the case now. The relays used for the project are fairly small (Tianbo HJR 1-2C L-12V, footprint 10x20mm) and the finder footprint looks too big to me I’ll have another play later, other priorities must take precedence now. Many thanks so far!

Well, solved the issue by creating my own symbol and footprint for the aforementioned Tianbo relay. But I also found Kicad relies on pin numbers matching between symbol and footprint to make connections in PCBnew. As at first, I’d only made the footprint, with appropriate pin numbers, but only one pin showed up in the ratsnest as that pin number accidentally corresponded between them. Only when I created a new symbol, with correct pin numbers, did the full (missing) ratsnest appear and was PCBnew able to complete the routing of all tracks from the netlist.

Need help, I can see the relay layout for all the Finders, but netlist importer on pcbedit tool, blows up.

If I remove the relays from the schematic, redo the process everything works and I get netlist to start routing
so pretty sure its the Relay_THT library.

Have no idea hot to fix it.

Please advise. I am on latest (this mornings) 4.0.7 also tried nightly build same result.

Thanks J

If you can still edit this post, I’d change it to:

“the pin numbers of the symbol you use agree with the pad numbers of the footprint you use.”

My intent is just such that your information remains consistent; (I knew what you meant, but newbies that find this post might be confused).

1 Like

Sorry your post has been ignored for so long.

You need to add the Relays_THT lib to your fp-lib-table.
Use the library wizard found in pcb_new->preferences for this job.

@Sprig thanks for your advice. (I seem to have been tired when i wrote my post.)