Pcbnew, EESchema crash after Windows 10 Update


I have been using Kicad 5.1.5 for quite some time on my Windows 10 64-BIT Laptop.
Windows got updated recently and since then EEScheama, PCBNew crashes just after opening.

Going through forum, I manually changed the Display preference, “canvas_type=2” from Modern Accelerated to Modern Fallback. Now I can start both EESchema/PCBNew but switching to Accelerated Mode crashes everything again.

All graphics drivers are up to date. Intel HD Graphics 520 & AMD Radeon R5 M430.
Reinstalling Kicad or even switching to previous version of Kicad makes no difference to problem.

Any solution to this problem?
Thanks in advance.


Have you tried deleting the complete content of the configuration folder in %appdata%/kicad ?


Yes. I did try deleting kicad config completely & reinstalling kicad again. EESchema/PCBnew crashed on start without any error message, also main kicad application also gets terminated.
Looking into %appdata%roaming%kicad, I found that no config files were present, except fp-lib-table & sym-lib-table.


Somebody was having a similar problem last time, I post him my configuration folder and it help him get up an running, you could try that.

On the other hand, if the configuration folder is empty (library tables shouldn’t matter here at all) after KiCad is started and crashed, it means that it can’t get very far and an existing configuration doesn’t help (except for setting the fallback mode, which was already mentioned as working). The only thing which comes to mind is antialiasing settings, which doesn’t hurt to test.

Unfortunately these hardware/driver/OpenGL problems are very difficult to hunt down and fix. Unless some developer happens to have access to a similar or identical hw/driver/OS combination it can’t be debugged or even verified. And because it happens in OpenGL code it requires specialized knowledge AFAIK.

1 Like


It seems Windows update somehow messed up with display drivers. A complete cleanup of drivers using Display Driver Uninstaller (DDU) & reinstalling drivers have fixed the issue.

Thanks for the help.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.