PCBNew deosen't show silk screen


#1

Hello!

I’m close to the end of this PCB set, and I have the following problem. On the PCB view, the silk screen is not shown if I use copper filling. But if I check with the 3D viewer, the silk screen is drawn. Can I assume it will look like the 3D viewer shows it?
Here is an example of a part of an adaptor board where the version is written. Both in PCB new and 3D viewer.

Thanks for any hint.

Pascal

Overview

Overview2


#2

The modern toolset shows the selected layer OVER all other layers in the editor area… you have to select the silkscreen layer to get it to the top so you can see it.
Also try it with the high contrast mode (a button to the left) when you have a layer on the right selected as active, makes it easier to just see this layer and all else tones down.

If you’re keen there are opacity settings if you double-click on the color block next to each layer level. But I don’t think it will really help your case…


#3

OK, Thanks Joan!
I just wanted to be sure I will receive my PCBs with a silk screen.
Thanks for your help!
Pascal


#4

The editing view is for editing the board, not for realistic view. You must use the Plot function to create gerbers, you don’t (usually) send KiCad files to a manufacturer. Gerbers tell which layers you will get.


#5

You should then check all your Gerber layers using KiCad’s Gerber viewer tool:

Also, some PCB manufacturers can generate a realistic rendering of your PCB before placing the order (PCBgogo and Eurocircuits do that for example, the later also providing an excellent PCB analysis tool to check that your board is within manufacturing specs).


#6

As much as I like kicad but I would suggest to check gerbers with an independent tool. (If kicad has a bug in gerber generation then the same bug will be in the gerber viewer as well.) I personally use gerbv from the geda project.