PCBNew del duplicate trace. how to disable?


#1

I like to have double trace (top & bottom) for power runs when I can. There used to be a way to permit this, but now I can’t find it. No mention in current help doc.
thanks
Barry

Application: kicad
Version: (6.0.0-rc1-dev-373-g32d262b0f), release build
Libraries:
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#2

There is a button in the left toolbar for that.


#3

What? I never knew there would be such a feature, and certainly there’s no such button. I can’t that kind of feature (namely ability to lay down top&bottom tracks at the same time) anywhere.


#4

The button was in v4. In v5.0.1 it isn’t anymore.

Preferences -> General settings -> autodelete old tracks (for legacy toolset)

Route -> interactive route settings -> remove redundant tracks (for modern toolset)


#5

Pedro - thanks! That is exactly what I was looking for. Having the setting in 2 places would have confused me forever if I’d have found only 1.

Yes the button disappeared in V5. I didn’t notice it was gone until I needed it.

Thanks again everyone
Barry