PCBnew crashes, won't open in Ubuntu 18.04


Pcbnew is refusing to open in Ubuntu 18.04. I have projects that I have been working on that open the schematic but fail on PCBnew. I have tried different projects getting the same result. When trying the projects on a windows machine they open with no issue.

I also tried opening opening PCBnew individually (without the project explorer) it did not open.

I would appreciate any help or directions on where to find log files with info.


1 Like

I just noticed that he “PCB Footprint Editor” won’t open either. Every other program is fine.

1 Like

I already reported this to the bug tracker, so the developers are aware.

It seems this is not necessarily a new issue. Check this old bug report.

1 Like

Please report this to Ubuntu (https://bugs.launchpad.net/ubuntu/+source/kicad/+bug/1769220). This is a library issue.

It would be very helpful if you would also submit the crash report to them (run ubuntu-bug kicad if you are running the bog-standard 4.0.7)

The command you gave above returns an error. I suppose that means I’m not running the “bog-standard 4.07”. Any other ideas on how I can get the crash report?

You may find them in /var/crash but if not, you can follow step here (https://help.ubuntu.com/community/ReportingBugs) to enable apport.

Thanks. I’ve submitted it.

1 Like

I have PCs running KiCad on 17.10 which reaches EOL in July, forcing a move to 18.04.
I hope that this gets resolved soon.

I followed advice to try installing the nightly build and it worked. So I will just stick with it. If you prefer staying on the stable release I suggest you wait for a patch from the devs.

PCBnew kept crashing, same as others above reported. I removed scripts from ~/.kicad_plugins directory and resolved the crash issue.

Fresh, clean Ubuntu 18.04 install.

KiCAD Info:
Application: kicad
Version: 5.0.0-rc2-unknown-da66005~65~ubuntu18.04.1, release build
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-22-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.